Bug 1734426 - python-httpretty fails to build in Fedora 31: No matching package to install: 'python2-tornado'
Summary: python-httpretty fails to build in Fedora 31: No matching package to install:...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-httpretty
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jamie Lennox
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PYTHON38 PY2FTBI F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-30 14:04 UTC by Miro Hrončok
Modified: 2019-08-06 08:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 07:39:17 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-07-30 14:04:04 UTC
See https://koji.fedoraproject.org/koji/taskinfo?taskID=36637127

python-httpretty python-httpretty-0.9.5-6.fc31 fails to build in Fedora 31 with:

No matching package to install: 'python2-tornado'

The python2-tornado was removed based on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/ZXXOWINEGTILQRKCYZS43L6E4Y6EV5LI/

Please drop the build dependency on python2-tornado and make the package build.

This blocks the Python 3.8 rebuild.

Comment 2 Miro Hrončok 2019-08-06 08:50:00 UTC
Note that python-boto-0:2.45.0-12.fc31.src BuildRequires python2-httpretty and the maintainer(s) will likely be surprised by your fix of the problem.


Note You need to log in before you can comment on or make changes to this bug.