Bug 1734485 - upstream test torture_threads_pki_rsa fails in FIPS mode
Summary: upstream test torture_threads_pki_rsa fails in FIPS mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: libssh
Version: 8.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.1
Assignee: Anderson Sasaki
QA Contact: Ondrej Moriš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 16:40 UTC by Ondrej Moriš
Modified: 2019-11-05 22:36 UTC (History)
3 users (show)

Fixed In Version: 0.9.0-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:36:03 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3657 None None None 2019-11-05 22:36:15 UTC

Description Ondrej Moriš 2019-07-30 16:40:26 UTC
Description of problem:

When FIPS mode is enabled, libssh upstream testsuite fails as follows:

98% tests passed, 1 tests failed out of 56
Total Test time (real) = 122.54 sec
The following tests FAILED:
 33 - torture_threads_pki_rsa (Failed)

Version-Release number of selected component (if applicable):

libssh-0.9.0-3.el8

How reproducible:

100% in FIPS mode

Steps to Reproduce:

1. Enabled FIPS mode
   # fips-mode-setup --enable && reboot

2. Build libssh source rpm and execute upstream tests

Actual results:

See above (1 test fails).

Expected results:

All tests are passed or skipped (if they are not FIPS compatible).

Additional info:

When FIPS mode is disabled, test passes.

Comment 5 errata-xmlrpc 2019-11-05 22:36:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3657


Note You need to log in before you can comment on or make changes to this bug.