Bug 17345 - glibc upgrade causes strange umount problem
Summary: glibc upgrade causes strange umount problem
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-08 03:12 UTC by Viraj Alankar
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 03:12:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Viraj Alankar 2000-09-08 03:12:49 UTC
Upgrading stock 6.2 glibc to:

glibc-2.1.3-19.i386.rpm
glibc-devel-2.1.3-19.i386.rpm

causes a strange problem that I'm able to duplicate on similar machines. 
After doing the upgrade with rpm -Fvh, rebooting the system causes:

Unmounting file systems umount2: Device or resource busy
umount: /: device is busy

mount: / is busy
Unmounting proc file system
mount: / is busy

The system is then rebooted, and an fsck is run at next bootup. Rebooting 
again causes no problems.

Comment 1 Jakub Jelinek 2000-09-10 20:05:45 UTC
That's because init was still using the old glibc at reboot time.
Run telinit u after upgrading glibc if you want clean reboots after
glibc upgrade.
I have already coded a program which will take care of doing
telinit u on upgrades (it is tricky because of package dependencies),
it will appear in the next glibc 2.1.93+ build.


Note You need to log in before you can comment on or make changes to this bug.