Bug 1734533 - Retire jbuilder?
Summary: Retire jbuilder?
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jbuilder
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ben Rosser
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 19:31 UTC by Jerry James
Modified: 2019-08-01 13:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-01 13:58:33 UTC


Attachments (Terms of Use)

Description Jerry James 2019-07-30 19:31:14 UTC
Description of problem:
It appears that at some point the jbuilder package was renamed to ocaml-dune, but the jbuilder package was never retired.  That means we now have two conflicting packages, jbuilder and ocaml-dune, in Fedora.

Version-Release number of selected component (if applicable):
jbuilder-1.0.1-3.fc31
ocaml-dune-1.10.0-3.fc31

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ben Rosser 2019-07-30 21:02:51 UTC
I actually thought this had already happened. :( Yes, jbuilder should be retired in favor of ocaml-dune.

Comment 2 Ben Rosser 2019-07-30 21:06:01 UTC
I've ran fedpkg retire.

https://src.fedoraproject.org/rpms/jbuilder/blob/master/f/dead.package

Do I need to do anything else, or will the rest happen automatically?

Comment 3 Ben Rosser 2019-08-01 13:58:33 UTC
Closing as "Rawhide", let me know if something else needs doing.


Note You need to log in before you can comment on or make changes to this bug.