Bug 1734582 - nothing provides nodejs-libs(x86-64) = 1:12.6.0-1.fc31 needed by nodejs-1:12.6.0-1.fc31.1.x86_64
Summary: nothing provides nodejs-libs(x86-64) = 1:12.6.0-1.fc31 needed by nodejs-1:12....
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2019-07-30 23:49 UTC by Miro Hrončok
Modified: 2019-07-31 12:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 12:00:03 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2019-07-30 23:49:32 UTC
nodejs just went uninstallable after the mass rebuild:

nothing provides nodejs-libs(x86-64) = 1:12.6.0-1.fc31 needed by nodejs-1:12.6.0-1.fc31.1.x86_64


This is caused by a combination of:

1) complicated Release magic that made the rpmdev-bumspec use microbump to nodejs-1:12.6.0-1.fc31.1

2) Requires: nodejs-libs%{?_isa} = %{epoch}:%{nodejs_version}-%{nodejs_release}%{?dist}

I suggest the line in 2 is updated to simple:

Requires: nodejs-libs%{?_isa} = %{epoch}:%{version}-%{release}

In fact, I'll send a PR.

Comment 1 Tom Hughes 2019-07-30 23:56:28 UTC
Yeah this always happens when somebody tries to mechanically bump the rev.

Comment 2 Tom Hughes 2019-07-30 23:59:02 UTC
New build running: https://koji.fedoraproject.org/koji/taskinfo?taskID=36697164

Comment 3 Miro Hrončok 2019-07-31 00:05:05 UTC
A long term fix proposed in https://src.fedoraproject.org/rpms/nodejs/pull-request/5

Comment 4 Miro Hrončok 2019-07-31 00:07:07 UTC
Tom, the broken nodejs build needs to be untagged first or the package needs to be rebootstraped.


Note You need to log in before you can comment on or make changes to this bug.