Bug 1734601 - The statefulset created with default yaml will get error in page after add storage to it
Summary: The statefulset created with default yaml will get error in page after add st...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 03:07 UTC by Yanping Zhang
Modified: 2019-10-16 06:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
error-page (106.79 KB, image/png)
2019-07-31 03:07 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:34:20 UTC

Description Yanping Zhang 2019-07-31 03:07:19 UTC
Created attachment 1594899 [details]
error-page

Description of problem:
After add storage to statefulset created with default yaml, the statefulset page will get error:
"Oh no! Something went wrong."

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-30-155738
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:67c0c09f5ea21e0a777a17aaf0331fbfdf910052126412c9f84865eb5779bf8a

How reproducible:
Always

Steps to Reproduce:
1.Create a statefulset with default yaml in project on console.
2.Add storage to the statefulset.
3.

Actual results:
2.After added storage, the statefulset page got error: "Oh no! Something went wrong."
For more info pls refer to screenshot.

Expected results:
2. Should not get error in page.

Additional info:

Comment 1 Jakub Hadvig 2019-07-31 19:36:11 UTC
PR: https://github.com/openshift/console/pull/2233

Comment 3 Yanping Zhang 2019-08-02 05:09:23 UTC
4.2.0-0.nightly-2019-08-01-113533
Checked on ocp 4.2 env with above version. Now create statefulset with default yaml, and add storage to the statefulset, there is no error now.
The bug has been fixed, so move it to Verified.

Comment 4 errata-xmlrpc 2019-10-16 06:34:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.