Bug 173463 - [MODULAR X] $HOME/bin not in $PATH
[MODULAR X] $HOME/bin not in $PATH
Status: CLOSED DUPLICATE of bug 173438
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-17 03:47 EST by jeroen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 11:51:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeroen 2005-11-17 03:47:54 EST
So i updated to modular X yesterday. Booted into it for the first time today.
The thing i noticed immediately was that it couldn't some scripts in had in
~/.Xclients. The scripts are located in $HOME/bin, but for some reason that is
no longer in my $PATH by default. It used to be in my $PATH by default with
monolithic X (or the old xinitrc package).
Comment 1 Kenneth Topp 2005-11-21 14:44:23 EST
bug seems to be this line in gdm's Xsession:

eval exec $sshagent $dbuslaunch $command

Needs to be "exec -l $SHELL ..." like in xinit.
Comment 2 Mike A. Harris 2005-11-22 22:43:10 EST
CC'ing the gdm maintainer

Ray, could you have a look?
Comment 3 Kenneth Topp 2005-11-23 14:28:56 EST
now we have #173438, I think that BaseXsession=/etc/X11/gdm/Xsession in gdm.conf
should point to /etc/X11/xinit/Xsession and we get rid of the gdm stored
Xsession since that's upstream and this is clearly redhat custom stuff
Comment 4 Mike A. Harris 2005-11-24 11:51:30 EST

*** This bug has been marked as a duplicate of 173438 ***

Note You need to log in before you can comment on or make changes to this bug.