Bug 1734700 - rbd map is taking more than 2 minutes to map the device on the node when there are more parallel requests
Summary: rbd map is taking more than 2 minutes to map the device on the node when ther...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: 4.0
Assignee: Ilya Dryomov
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 09:00 UTC by Madhu Rajanna
Modified: 2019-09-04 17:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-04 17:52:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Madhu Rajanna 2019-07-31 09:00:51 UTC
Description of problem:

rbd map is taking more than 2 minutes to map the device on the node when there are 50 parallel requests

when have seen this behavior in ceph-csi


Version-Release number of selected component (if applicable): ceph 12.2.2


How reproducible:
Always

Steps to Reproduce:
1.create 50/100 rbd images
2. map 50 rbd images on the node (parallel request)

Actual results:

for some requests, rbd map is taking more than 2 minutes to map images on node

Expected results:

rbd map should be completed in few seconds even if there are N number for parallel requests

Additional info:

link to the upstream issue https://github.com/ceph/ceph-csi/issues/507
there is a discussion is going on in upstream, creating this bug to track the same.

Comment 1 Jason Dillaman 2019-09-04 17:52:28 UTC
This was due to an extremely resource constrained environment and extra IO induced by running mkfs.ext4. The RBD CSI driver has switched to using XFS as its default and the problem seems to be better as per the linked issue.


Note You need to log in before you can comment on or make changes to this bug.