Bug 1734729 - [RFE] Update vdsm-jsonrpc-java to use OpenJDK 11 - both build and runtime
Summary: [RFE] Update vdsm-jsonrpc-java to use OpenJDK 11 - both build and runtime
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: vdsm-jsonrpc-java
Classification: oVirt
Component: General
Version: 1.4.18
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.4.0
: ---
Assignee: Artur Socha
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1734716
TreeView+ depends on / blocked
 
Reported: 2019-07-31 10:10 UTC by Martin Perina
Modified: 2020-05-20 20:01 UTC (History)
4 users (show)

Fixed In Version: 1.5.0
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-20 20:01:25 UTC
oVirt Team: Infra
mperina: ovirt-4.4?
pelauter: planning_ack+
mperina: devel_ack+
lleistne: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 103450 0 'None' MERGED Java 11 migration 2020-05-07 07:37:26 UTC
oVirt gerrit 105114 0 master MERGED jsonrpc: version bump to 1.5.0 2020-05-07 07:37:26 UTC
oVirt gerrit 105145 0 master MERGED jsonrpc: client version bumped to 1.5.2 2020-05-07 07:37:26 UTC

Description Martin Perina 2019-07-31 10:10:44 UTC
vdsm-jsonrpc-java needs to align with oVirt engine and use OpenJDK 11 instead of 8

Comment 4 Petr Matyáš 2020-01-21 14:34:13 UTC
Verified on vdsm-jsonrpc-java-1.5.2-1.el7.noarch

Comment 5 Sandro Bonazzola 2020-05-20 20:01:25 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.