Bug 1734739 - Fatal error and traceback during registration/status: FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'
Summary: Fatal error and traceback during registration/status: FileNotFoundError: [Err...
Keywords:
Status: CLOSED DUPLICATE of bug 1733221
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: insights-client
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: 8.0
Assignee: jcrafts
QA Contact: Jeff Needle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 10:40 UTC by Fred Uggla
Modified: 2019-07-31 15:28 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 15:28:05 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
verbose command output and logs (35.24 KB, application/gzip)
2019-07-31 10:40 UTC, Fred Uggla
no flags Details

Description Fred Uggla 2019-07-31 10:40:22 UTC
Created attachment 1595017 [details]
verbose command output and logs

Description of problem:

When checking the status and/or registering using the insights-client a fatal error occurs and a traceback is printed. The registration still works.


Version-Release number of selected component (if applicable):

3.0.5-4.el8


How reproducible:

I've reproduced it on three different VMs, but all are based on the same image/template. 


Steps to Reproduce:

1. dnf install insights-client
2. insights-client --register --verbose
3. insights-client --status --verbose


Actual results:

The commands works as expected, but there's a traceback printed even though I've not added the "--verbose" flag.

# insights-client --status
Fatal error
Traceback (most recent call last):
  File "/var/lib/insights/last_stable.egg/insights/client/phase/v1.py", line 32, in _f
    func(client, config)
  File "/var/lib/insights/last_stable.egg/insights/client/phase/v1.py", line 131, in post_update
    print_egg_versions()
  File "/var/lib/insights/last_stable.egg/insights/client/utilities.py", line 262, in print_egg_versions
    env={'PYTHONPATH': egg, 'PATH': os.getenv('PATH')}, stdout=PIPE, stderr=STDOUT)
  File "/usr/lib64/python3.6/subprocess.py", line 729, in __init__
    restore_signals, start_new_session)
  File "/usr/lib64/python3.6/subprocess.py", line 1364, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: 'python': 'python'
System is registered locally via .registered file. Registered at 2019-07-31T11:56:08.507700
Insights API confirms registration.


Expected results:

User friendly output and not a traceback, e.g. "The Ingihts API conforms registration but an error occured." 


Additional info:

The attached archive contains the insight-client logs and output from:
# insights-client --register --verbose
# insights-client --status --verbose

Comment 1 Jeff Needle 2019-07-31 15:28:05 UTC

*** This bug has been marked as a duplicate of bug 1733221 ***


Note You need to log in before you can comment on or make changes to this bug.