Bug 1734761 - OpenStack TripleO fails on ceph-ansible not having grafana-server node [NEEDINFO]
Summary: OpenStack TripleO fails on ceph-ansible not having grafana-server node
Keywords:
Status: CLOSED DUPLICATE of bug 1734525
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 11:22 UTC by Pavel Sedlák
Modified: 2019-07-31 12:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 12:02:43 UTC
Target Upstream Version:
fpantano: needinfo? (psedlak)


Attachments (Terms of Use)
output of overcloud deploy (3.98 MB, text/plain)
2019-07-31 11:27 UTC, Pavel Sedlák
no flags Details
/var/lib/mistral/overcloud/ceph-ansible/inventory.yml (527 bytes, text/plain)
2019-07-31 11:28 UTC, Pavel Sedlák
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 673675 None None None 2019-07-31 12:06:52 UTC

Description Pavel Sedlák 2019-07-31 11:22:38 UTC
OSP15 TripleO deployment fails in ceph-ansible not having any host in grafana-server group.

> "fatal: [controller-0]: FAILED! => changed=false ",
> "  msg: you must add a [grafana-server] group and add at least one node.",
> "fatal: [ceph-0]: FAILED! => changed=false ",


> ceph-ansible-4.0.0-0.1.rc13.el8cp.noarch
> ansible-2.8.3-1.el8ae.noarch
> python3-tripleoclient-11.5.1-0.20190723181704.f54216d.el8ost.noarch
> python3-tripleo-common-10.8.1-0.20190726121703.bd7d9ba.el8ost.noarch
> openstack-tripleo-common-10.8.1-0.20190726121703.bd7d9ba.el8ost.noarch



Appears in all OSP Phase2 CI jobs with ceph in topology.

Comment 1 Pavel Sedlák 2019-07-31 11:27:32 UTC
Created attachment 1595045 [details]
output of overcloud deploy

Comment 2 Pavel Sedlák 2019-07-31 11:28:49 UTC
Created attachment 1595046 [details]
/var/lib/mistral/overcloud/ceph-ansible/inventory.yml

Comment 6 John Fulton 2019-07-31 12:08:04 UTC

*** This bug has been marked as a duplicate of bug 1734525 ***


Note You need to log in before you can comment on or make changes to this bug.