Bug 1734778 - LVM cache feature not possible with ansible-2.8
Summary: LVM cache feature not possible with ansible-2.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhhi
Version: rhhiv-1.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHHI-V 1.6.z Async Update
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1738502
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 12:17 UTC by SATHEESARAN
Modified: 2019-10-03 12:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
LVM cache configuration did not work with Ansible 2.8 because of changes to expected values for 'pvs' in the configuration file. This has been updated so that the correct syntax is used.
Clone Of:
: 1738502 (view as bug list)
Environment:
Last Closed: 2019-10-03 12:24:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2963 0 None None None 2019-10-03 12:24:08 UTC

Description SATHEESARAN 2019-07-31 12:17:01 UTC
Description of problem:
-----------------------
With Ansible-2.8, LV cache feature is not working.

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHV 4.3.5
Ansible-2.8.3

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. During deployment enable LV cache. with cache data disk as value


Actual results:
---------------
Failed to setup LV cache

Expected results:
-----------------
LV cache should be setup successfully


Additional info:
----------------
This issue is also reported by oVirt community user using Ansible-2.8
https://bugzilla.redhat.com/show_bug.cgi?id=1720261

Sachi is aware of this issue and has upstream issue - https://github.com/ansible/ansible/issues/56501 - opened for the same

Comment 1 SATHEESARAN 2019-07-31 12:18:13 UTC
As a workaround for this issue, Sachi has suggested to have the disk in the VG also as input along with cache disk

<snip>
Now since version 2.8 the behavior has changed, where all the existing pvs which which were part of volume group has to be provided. Like:

- name: Extend volume group
  lvg:
     state: present
     vg: foo_vg
     pvs: "/dev/sdb,/dev/sdc"
     pv_options: "--dataalignment 256K"
</snip>

Comment 2 SATHEESARAN 2019-07-31 12:22:03 UTC
Gobinda already has a patch that settles the issue[1] where the LV cache will be attached to the
specific thinpool, along with that patch, it will be easily deducible to find the PV of the VG.

With that information, ansible vars file could be having both the disks PV of that VG, and also the cache disk

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=1721451

Comment 3 SATHEESARAN 2019-09-03 05:13:05 UTC
Verified with cockpit-ovirt-dashboard-0.13.6
LVM cache code takes care of the problem now.

When the cache is created on 'sdc' to cache the contents of thinpool on 'sdb',
then the cache value in the generated vars file becomes - '/dev/sdb,/dev/sdc' as per expectation

Comment 5 errata-xmlrpc 2019-10-03 12:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2963


Note You need to log in before you can comment on or make changes to this bug.