Bug 1734855 - coccinelle: FTBFS in Fedora rawhide/f31
Summary: coccinelle: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: coccinelle
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1735387 (view as bug list)
Depends On:
Blocks: F31FTBFS F32FTBFS F32FailsToInstall PYTHON38 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 16:02 UTC by Fedora Release Engineering
Modified: 2019-10-03 00:36 UTC (History)
2 users (show)

Fixed In Version: coccinelle-1.0.8-0.1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-03 00:36:20 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2019-07-31 16:03 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 16:03 UTC, Fedora Release Engineering
no flags Details
state.log (633 bytes, text/plain)
2019-07-31 16:03 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 16:02:59 UTC
coccinelle failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36500468


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix coccinelle at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
coccinelle will be orphaned. Before branching of Fedora 32,
coccinelle will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 16:03:01 UTC
Created attachment 1595136 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2019-07-31 16:03:04 UTC
Created attachment 1595137 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 16:03:06 UTC
Created attachment 1595138 [details]
state.log

Comment 4 Richard W.M. Jones 2019-07-31 16:09:41 UTC
I raised this issue upstream a few weeks ago:

https://systeme.lip6.fr/pipermail/cocci/2019-July/thread.html#6101

Unfortunately there is no resolution yet.

Comment 5 Miro Hrončok 2019-08-01 22:56:18 UTC
*** Bug 1735387 has been marked as a duplicate of this bug. ***

Comment 6 Miro Hrončok 2019-08-01 22:56:55 UTC
This also blocks the Python 3.8 rebuild.

Comment 7 Ben Cotton 2019-08-13 16:54:50 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 8 Ben Cotton 2019-08-13 18:36:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 9 Miro Hrončok 2019-08-14 22:24:16 UTC
The coordinated rebuild of Python 3.8 has started in the `f32-python` side tag.

If you figure out how to rebuild this package, please don't rebuild it in regular rawhide, but use the side tag instead:

    on branch master:
    $ fedpkg build --target=f32-python

To wait for a build to show up in the side tag, do:

    $ koji wait-repo f32-python --build=<nvr>

Where <nvr> is name-version-release of the source package, e.g. python-foo-1.1-2.fc32.

An updated mock config is posted at:
http://copr.fedorainfracloud.org/coprs/g/python/python3.8/

Note that it will take a while before the essential packages are rebuilt, so don't expect all your dependencies to be available right away.

Thanks. Let us know if you need up to date info, or if you have any questions.



PS this message is mass posted to all the bugs that block the PYTHON38 bug. If this is also a Fedora 31 FTBFS bug and you manage to fix it, you can do a f31 build as usual:

    on branch f31:
    $ fedpkg build

Comment 10 Miro Hrončok 2019-08-21 16:34:29 UTC
The f32-python side tag has been merged. In order to rebuild the package, do it in regular rawhide, but please wait until python3-3.8 is tagged:

  $ koji wait-repo f32-build --build python3-3.8.0~b3-3.fc32


If your built already started in f32-python, after it is finished, please tag it to rawhide with:

  $ koji tag-build f32-pending <nvr>

For example:

  $ koji tag-build f32-pending libreoffice-6.3.0.4-3.fc32

Thanks!

(This comment is mass posted to all bugzillas blocking the PYTHON38 tracking bug.)

Comment 11 Miro Hrončok 2019-08-21 17:29:04 UTC
(Python 3.8 has landed in the rawhide buildroot.)

Comment 12 Miro Hrončok 2019-09-16 08:49:37 UTC
This issue is blocking the Python 3.8 rebuilds. If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32.
Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Could you please look into this?

Comment 13 Richard W.M. Jones 2019-09-17 11:47:12 UTC
I've looked into it again just now and still no movement upstream.  There's
unfortunately no way around this except to do the port ourselves, which I
attempted and gave up on because it's pretty complicated.

Note AFAIK this is a leaf package as far as Python is concerned, so it
shouldn't really block Python 3.8 rebuilds in any significant way.

Comment 14 Richard W.M. Jones 2019-09-24 08:09:26 UTC
Julia kindly provided me with a version of coccinelle which works
with OCaml 4.08 and I've now rebuilt it in Fedora Rawhide and F31.

Rawhide: https://koji.fedoraproject.org/koji/taskinfo?taskID=37836631
F31: https://koji.fedoraproject.org/koji/taskinfo?taskID=37836639

Comment 15 Fedora Update System 2019-09-24 08:11:10 UTC
FEDORA-2019-b3d6c21df0 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3d6c21df0

Comment 16 Fedora Update System 2019-09-25 01:38:08 UTC
coccinelle-1.0.8-0.1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-b3d6c21df0

Comment 17 Fedora Update System 2019-10-03 00:36:20 UTC
coccinelle-1.0.8-0.1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.