Bug 1734880 - ClanLib: FTBFS in Fedora rawhide/f31
Summary: ClanLib: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ClanLib
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1735412 (view as bug list)
Depends On:
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 16:06 UTC by Fedora Release Engineering
Modified: 2019-08-18 14:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-18 14:05:30 UTC


Attachments (Terms of Use)
build.log (42 bytes, text/plain)
2019-07-31 16:06 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 16:06 UTC, Fedora Release Engineering
no flags Details
state.log (473 bytes, text/plain)
2019-07-31 16:06 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 16:06:53 UTC
ClanLib failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36631567


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix ClanLib at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
ClanLib will be orphaned. Before branching of Fedora 32,
ClanLib will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 16:06:56 UTC
Created attachment 1595211 [details]
build.log

Comment 2 Fedora Release Engineering 2019-07-31 16:06:58 UTC
Created attachment 1595212 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 16:06:59 UTC
Created attachment 1595213 [details]
state.log

Comment 4 Hans de Goede 2019-08-08 15:33:20 UTC
*** Bug 1735412 has been marked as a duplicate of this bug. ***

Comment 5 Ben Cotton 2019-08-13 16:59:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 17:20:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Hans de Goede 2019-08-18 13:11:49 UTC
Looking at root.log, something went wrong on the buildsys during the mass-rebuild.

I'm going to kick off a new build and see if that fixes things.

Comment 8 Hans de Goede 2019-08-18 14:05:30 UTC
ClanLib has been successfully rebuild for F31+, closing.


Note You need to log in before you can comment on or make changes to this bug.