This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 173489 - kernel panics when rebooting
kernel panics when rebooting
Status: CLOSED DUPLICATE of bug 184523
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-11-17 10:57 EST by bjorn sandell
Modified: 2013-08-05 21:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 10:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Here a dmesg from an identical machine (18.32 KB, text/plain)
2005-11-17 11:32 EST, bjorn sandell
no flags Details

  None (edit)
Description bjorn sandell 2005-11-17 10:57:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; OpenBSD i386; en-US; rv:1.8) Gecko/20051113 Firefox/1.5

Description of problem:
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at spinlock:118
invalid operand: 0000 [1] SMP
CPU 0
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.9-22.0.1.ELsmp
RIP: 0010:[<ffffffff80303da8>] <ffffffff80303da8>{_spin_lock_irqsave+40}
RSP: 0000:ffffffff8044a6d8  EFLAGS: 00010092
RAX: 0000000000000016 RBX: 0000000000000000 RCX: 0000000000020000
RDX: 0000000000001c63 RSI: 0000000000000046 RDI: ffffffff803d78e0
RBP: 00000100080029e0 R08: 00000000fffffffe R09: 0000000000000000
R10: 0000000000000000 R11: 0000000000000000 R12: ffffffff803f2480
R13: ffffffff8044a728 R14: 0000000000000206 R15: 0000000000000008
FS:  0000000000000000(0000) GS:ffffffff804d3080(0000) knlGS:0000000000000000
CS:  0010 DS: 0018 ES: 0018 CR0: 000000008005003b
CR2: 0000000000000000 CR3: 0000000000101000 CR4: 00000000000006e0
Process swapper (pid: 1, threadinfo 0000010082962000, task 0000010037e5b7f0)
Stack: ffffffff803f2480 0000000000000256 0000000000000000 ffffffff801461d0
       0000000000000000 ffffffff80231c39 ffffffff8044a728 ffffffff8014626e
       ffffffff8048fae0 ffffffff8013ee11
Call Trace:<IRQ> <ffffffff801461d0>{__queue_work+16} <ffffffff80231c39>{blank_sc
reen_t+0}
       <ffffffff8014626e>{queue_work+80} <ffffffff8013ee11>{run_timer_softirq+35
6}
       <ffffffff8013b684>{__do_softirq+88} <ffffffff8013b72d>{do_softirq+49}
       <ffffffff80110951>{apic_timer_interrupt+133}  <EOI> <ffffffff8023f62f>{se
rial_in+83}
       <ffffffff80241722>{serial8250_console_write+113} <ffffffff80136ef0>{__cal
l_console_drivers+68}
       <ffffffff8013715d>{release_console_sem+276} <ffffffff801373e8>{vprintk+49
8}
       <ffffffff80137492>{printk+141} <ffffffff801f5163>{vgacon_cursor+0}
       <ffffffff801f5163>{vgacon_cursor+0} <ffffffff804e2e83>{setup_boot_APIC_cl
ock+73}
       <ffffffff804e27ba>{smp_prepare_cpus+3039} <ffffffff8010c257>{init+70}
       <ffffffff80110ca3>{child_rip+8} <ffffffff80204884>{acpi_ds_init_one_objec
t+0}
       <ffffffff8010c211>{init+0} <ffffffff80110c9b>{child_rip+0}

Code: 0f 0b db d5 31 80 ff ff ff ff 76 00 f0 fe 0b 0f 88 17 03 00
RIP <ffffffff80303da8>{_spin_lock_irqsave+40} RSP <ffffffff8044a6d8>
 <0>Kernel panic - not syncing: Oops


Version-Release number of selected component (if applicable):
Kernel 2.6.9-22.0.1.ELsmp

How reproducible:
Didn't try

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 bjorn sandell 2005-11-17 11:32:23 EST
Created attachment 121197 [details]
Here a dmesg from an identical machine
Comment 3 Jim Paradis 2006-02-09 17:15:56 EST
Have you tried the U3 beta kernel?  If so, does the problem persist?  There is a
fix for another similar-looking problem in U3, we hope it fixes this one as well.



Comment 4 bjorn sandell 2006-03-08 15:01:47 EST
No, I haven't tried U3 beta (nor U3); it is production machines so I can't. I
have only seen the panic once in maybe 10 or 15 reboots so it's not very common.
Comment 6 Jason Baron 2006-03-14 10:02:35 EST

*** This bug has been marked as a duplicate of 184523 ***
Comment 7 Linda Wang 2006-05-09 17:47:31 EDT
errata tool clean up, add to U4 CANFIX list for tracking purposes.

Note You need to log in before you can comment on or make changes to this bug.