Bug 1734942 - arpack: FTBFS in Fedora rawhide/f31
Summary: arpack: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: arpack
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1735460 (view as bug list)
Depends On:
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 17:01 UTC by Fedora Release Engineering
Modified: 2019-11-30 18:51 UTC (History)
6 users (show)

Fixed In Version: arpack-3.7.0-3.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-30 18:51:50 UTC


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2019-07-31 17:12 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 17:13 UTC, Fedora Release Engineering
no flags Details
state.log (617 bytes, text/plain)
2019-07-31 17:13 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 17:01:10 UTC
arpack failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36632032


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix arpack at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
arpack will be orphaned. Before branching of Fedora 32,
arpack will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 17:12:59 UTC
Created attachment 1595392 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2019-07-31 17:13:01 UTC
Created attachment 1595393 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 17:13:03 UTC
Created attachment 1595394 [details]
state.log

Comment 4 Susi Lehtola 2019-08-02 10:23:01 UTC
*** Bug 1735460 has been marked as a duplicate of this bug. ***

Comment 5 Susi Lehtola 2019-08-02 10:30:42 UTC
Looks like rathann is already on this
https://github.com/opencollab/arpack-ng/issues/195

Comment 6 Ben Cotton 2019-08-13 16:59:33 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 7 Ben Cotton 2019-08-13 18:35:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 8 Orion Poplawski 2019-11-28 19:13:44 UTC
So, the problem here is that arpack doesn't really support SYMBOLSUFFIX to change the BLAS/LAPACK symbol names, so the current ILP64 build is using a mix of ILP64 configured arpack and 32-bit BLAS routines.  I'm working on a couple options for fixing this.

Easiest to do is to switch to using the non-symbol suffixed version of openblas, which I think we should rename to "arpack64" instead of "arpack64_".  PR filed here: https://src.fedoraproject.org/rpms/arpack/pull-request/1

I'm still poking at trying to support a symbol suffixed version.


Note You need to log in before you can comment on or make changes to this bug.