Bug 1734973 - possible segfault in systemtap.bpf with foreach string key iteration
Summary: possible segfault in systemtap.bpf with foreach string key iteration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemtap
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Serguei Makarov
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-31 17:46 UTC by Serguei Makarov
Modified: 2019-11-05 20:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:55:09 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
patch with reproducer testcase and bugfix (3.36 KB, text/plain)
2019-07-31 17:46 UTC, Serguei Makarov
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3366 None None None 2019-11-05 20:55:17 UTC

Description Serguei Makarov 2019-07-31 17:46:10 UTC
Created attachment 1595459 [details]
patch with reproducer testcase and bugfix

Description of problem:

https://sourceware.org/git/gitweb.cgi?p=systemtap.git;a=commitdiff;h=e037dc796de75b0d9e7e893fba6a39c2837aca2b

In some circumstances foreach iteration with string keys in systemtap 4.1 can trigger a segfault in the userspace stapbpf interpreter.

Version-Release number of selected component (if applicable):
systemtap-4.1-3

How reproducible:

Use testcase foreach_string.stp provided in above patch.


Steps to Reproduce:
1. $ sudo stap -v --bpf foreach_string.stp.

Actual results:
Terminates with segfault.

Expected results:
No segfault.


Additional info:

Comment 6 errata-xmlrpc 2019-11-05 20:55:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3366


Note You need to log in before you can comment on or make changes to this bug.