Bug 173498 - libtunepimp: A library for creating MusicBrainz enabled tagging applications
libtunepimp: A library for creating MusicBrainz enabled tagging applications
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
David Lawrence
http://musicbrainz.org/products/tunep...
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-11-17 12:08 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-20 14:29:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-11-17 12:08:44 EST
Spec Name or Url: http://apt.kde-redhat.org/apt/kde-redhat/SPECS/libtunepimp-0.4.0-1.spec
SRPM Name or Url: http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.unstable/libtunepimp-0.4.0-1.src.rpm
Description: 
The TunePimp library (also referred to as libtunepimp) is a development library geared towards developers who wish to create MusicBrainz enabled tagging applications.

%changelog
* Thu Nov 17 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.4.0-1
- 0.4.0
- built with --enable-lgpl which omits mp3 plugin bits
Comment 1 Rex Dieter 2005-11-17 12:16:10 EST
Library (Theoretically) usable by: kdemultimedia(extras/juk), amarok
Comment 2 Rex Dieter 2005-11-17 15:00:19 EST
FYI, 

amarok requires patching to use the new libtunepimp, see
http://bugs.kde.org/94988

kdemultimedia(-3.5.0) as well:
http://bugs.kde.org/116575
Comment 3 Ville Skyttä 2005-11-17 15:38:11 EST
Do you happen to have any info whether the current kid3 in Extras would work 
with this version?  It should have support for libtunepimp, but I've never 
tried it out. 
Comment 4 Rex Dieter 2005-11-17 15:57:00 EST
I'll go check it out.
Comment 5 Rex Dieter 2005-11-17 16:05:37 EST
Looks like kid3 uses code similar to both juk and amarok, and will need to be
likewise patched (the api changed a wee bit from lintunepimp-0.3.0 to 0.4.0).
Comment 6 Aurelien Bompard 2005-11-19 05:01:15 EST
Missing BR: zlib-devel and libvorbis-devel.
Also, it is BR: libmusicbrainz-devel and not BR: libmusicbrainz
Comment 7 Rex Dieter 2005-11-19 13:11:46 EST
FYI, see also libtunepimp-mp3 submission to livna:
http://bugzilla.livna.org/show_bug.cgi?id=637
Comment 8 Rex Dieter 2005-11-19 13:18:08 EST
Spec Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/SPECS/libtunepimp-0.4.0-2.spec
SRPM Name or Url:
http://apt.kde-redhat.org/apt/kde-redhat/all/SRPMS.unstable/libtunepimp-0.4.0-2.src.rpm

%changelog
* Sat Nov 19 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.4.0-2
- BR: libmusicbrainz -> libmusicbrainz-devel
- BR: libogg-devel -> libvorbis-devel
- BR: zlib-devel
Comment 9 Aurelien Bompard 2005-11-20 00:41:39 EST
Review for release 2:
* RPM name is OK
* Source libtunepimp-0.4.0.tar.gz is the same as upstream
* This is the latest version
* Builds fine in mock
* rpmlint of libtunepimp looks OK
* rpmlint of libtunepimp-devel looks OK
* File list of libtunepimp looks OK
* File list of libtunepimp-devel looks OK
* Works fine
APPROVED

I've added the patch to amarok, will request a rebuild when this is published.
Comment 10 Rex Dieter 2005-11-20 14:29:17 EST
Thanks, imported.
Comment 11 Ville Skyttä 2005-11-20 15:21:03 EST
No component for this yet in Bugzilla, so I'll spam here: some of the headers      
in -devel contain susceptible #includes that aren't shipped in it (and -devel   
has no other -devel deps, and even if it did, these would look more or less 
strange):   
   
track.h:#include "mutex.h"  
track.h:#include "metadata.h"  
track.h:#include "filelookup.h"  
tunepimp.h:#include "mutex.h"  
tunepimp.h:#include "filecache.h"  
tunepimp.h:#include "analyzer.h"  
tunepimp.h:#include "submit.h"  
tunepimp.h:#include "lookup.h"  
tunepimp.h:#include "filelookup.h"  
tunepimp.h:#include "write.h"  
tunepimp.h:#include "readmeta.h"  
tunepimp.h:#include "plugins.h"      
Comment 12 Rex Dieter 2005-11-21 09:06:33 EST
Ville, 
Yeah, clearly the C++ API is not finalized, and some of the included headers
don't seem 100% usable (ie, tunepimp.h).  The only header I know that
libtunepimp-using apps are actively using is tp_c.h.
Comment 13 Ville Skyttä 2005-11-21 13:27:55 EST
Ok, in that case I'd suggest purging the currently unusable headers from the 
-devel package (track.h, tunepimp.h unless I missed something) in order to 
avoid confusion. 

Note You need to log in before you can comment on or make changes to this bug.