Bug 1735023 - clufter: FTBFS in Fedora rawhide/f31
Summary: clufter: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: clufter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Pokorný [poki]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 17:59 UTC by Fedora Release Engineering
Modified: 2019-09-23 13:25 UTC (History)
1 user (show)

Fixed In Version: clufter-0.77.2-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-23 13:25:24 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2019-07-31 17:59 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 17:59 UTC, Fedora Release Engineering
no flags Details
state.log (625 bytes, text/plain)
2019-07-31 18:00 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 17:59:45 UTC
clufter failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36632396


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix clufter at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
clufter will be orphaned. Before branching of Fedora 32,
clufter will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 17:59:48 UTC
Created attachment 1595606 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2019-07-31 17:59:55 UTC
Created attachment 1595607 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 18:00:03 UTC
Created attachment 1595608 [details]
state.log

Comment 4 Ben Cotton 2019-08-13 16:58:58 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 Ben Cotton 2019-08-13 18:43:42 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Fedora Release Engineering 2019-09-22 04:24:02 UTC
Dear Maintainer,

your package has not been built successfully in 31. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 32 according to the schedule [3],
any packages which still have open FTBFS bugs from Fedora 31 will be retired.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/32/Schedule

Comment 7 Jan Pokorný [poki] 2019-09-23 13:25:24 UTC
The problem here was (see [comment 1]):

> + [[ /usr/bin/python3 -I =~  - ]]
> + echo 'ERROR py_byte_compile: Path to interpreter should not contain any arguments'
> BUILDSTDERR: ERROR py_byte_compile: Path to interpreter should not contain any arguments
> + exit 1

The cause was, IIRC, having a python-executable related varilable set to command name
incl. some security related switches, see:

https://src.fedoraproject.org/rpms/clufter/pull-request/2

Hence, closing this bug, sorry for late response.


Note You need to log in before you can comment on or make changes to this bug.