Bug 173508 - anaconda crashes after rpm not found
anaconda crashes after rpm not found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-17 13:18 EST by Stefan Geuns
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-17 19:05:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Geuns 2005-11-17 13:18:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Anaconda crashes after a file is not found when doing a http installation.
I downloaded lots of rpms from the download site together with the repodata and file in the base directory. Problem is that I didn't download all required packages but they are still in the repo files since I downloaded those too. Now anaconda can't find them, tries to download them 5 times (according to apache access logs) and crashes.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download some rpms from a mirror and the repodata and base directory and putt them in your apache dir
2. Boot boot.iso and wait untill installation from rpms starts
3. View crash report generated by anaconda
  

Actual Results:  Crash window opened with a traceback.

Expected Results:  Anaconda should say that the file was not found and ask me if I want to get it of another mirror.

Additional info:

Short summary (cause I had to type it over)

File: /usr/lib/anaconda/gui.py line 1195 in renderHandleCallback 
File: /usr/lib/anaconda/iw/progress_gui.py line 245 in renderCallback
File: /usr/lib/anaconda/gui.py line 924 in nextClicked
Comment 1 Jeremy Katz 2005-11-17 19:05:41 EST
Fixed in CVS
Comment 2 Stefan Geuns 2005-11-21 08:16:51 EST
Still crashes today. Downloaded latest boot.iso, stage2.img and anaconda.rpm and
updated my repodata. Error report says the same lines as before.

How to recreate:
download development tree to a local webserver and delete 1 file (like
kernel...rpm) from it, now try to install fedora with boot.iso through http.

Note You need to log in before you can comment on or make changes to this bug.