Bug 1735128 - eclipse-jgit: FTBFS in Fedora rawhide/f31
Summary: eclipse-jgit: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-jgit
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FTBFS 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 18:40 UTC by Fedora Release Engineering
Modified: 2019-09-24 01:42 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-24 01:42:14 UTC


Attachments (Terms of Use)
build.log (1.20 KB, text/plain)
2019-07-31 18:40 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 18:40 UTC, Fedora Release Engineering
no flags Details
state.log (481 bytes, text/plain)
2019-07-31 18:40 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 18:40:13 UTC
eclipse-jgit failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36633070


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix eclipse-jgit at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
eclipse-jgit will be orphaned. Before branching of Fedora 32,
eclipse-jgit will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 18:40:16 UTC
Created attachment 1595893 [details]
build.log

Comment 2 Fedora Release Engineering 2019-07-31 18:40:18 UTC
Created attachment 1595894 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 18:40:19 UTC
Created attachment 1595895 [details]
state.log

Comment 4 Ben Cotton 2019-08-13 17:06:00 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 Ben Cotton 2019-08-13 18:46:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Zbigniew Jędrzejewski-Szmek 2019-09-12 08:31:52 UTC
This is breaking upgrades to F31:

>  Problem 1: problem with installed package eclipse-jgit-5.4.0-4.fc30.noarch
>   - eclipse-jgit-5.4.0-4.fc30.noarch does not belong to a distupgrade
> repository
>   - nothing provides jgit = 5.3.0-5.fc31 needed by
> eclipse-jgit-5.3.0-5.fc31.noarch

Comment 7 Mikolaj Izdebski 2019-09-12 08:39:59 UTC
Can you explain how a FTBFS bug breaks upgrades?

Comment 8 Zbigniew Jędrzejewski-Szmek 2019-09-12 08:59:33 UTC
jgit was updated to 5.4.0 and eclipse-jgit is not installable now.

Comment 9 Mikolaj Izdebski 2019-09-12 09:00:39 UTC
Then this is a different issue and should be reported as a separate bug.

Comment 10 Zbigniew Jędrzejewski-Szmek 2019-09-12 09:07:22 UTC
It's pretty clear that both will be fixed at the same time. Entia non sunt multiplicanda praeter necessitatem.

Comment 11 Mikolaj Izdebski 2019-09-12 09:37:39 UTC
To me it's the opposite - it's pretty clear that the two issues are not very much related and that fixing FTBFS will not fix FTI (fails to install) bug - FTBFS is caused by dependency issues in ursine buildroots while FTI seems to be caused by modular packages shadowing ursine packages. Therefore, in order to be able to reproduce the FTI issue we need a separate bug open with all relevant details - which packages were installed at the time of upgrade attempt, which YUM repositories were enabled, which modules were enabled and so on.

Comment 12 Zbigniew Jędrzejewski-Szmek 2019-09-12 09:51:48 UTC
I can reproduce the same error easily on a F31 installation, and a clean F32 server install:
$ sudo dnf install eclipse-jgit
Last metadata expiration check: 2:26:12 ago on Thu Sep 12 09:17:37 2019.
Error: 
 Problem: conflicting requests
  - nothing provides jgit = 5.3.0-5.fc31 needed by eclipse-jgit-5.3.0-5.fc31.noarch
(try to add '--skip-broken' to skip uninstallable packages)

There might be some complex underlying issues, but I think this is for the maintainers to figure out.
From the POV of users (or packages who are not familiar with this particular package), a report like
this should be enough. It's an obvious bug (breaks upgrade path) and reproduction is trivial.

Comment 13 Fedora Update System 2019-09-18 14:44:49 UTC
FEDORA-MODULAR-2019-33a1b20f0a has been submitted as an update to Fedora 31 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2019-33a1b20f0a

Comment 14 Mat Booth 2019-09-18 14:47:21 UTC
(In reply to Zbigniew Jędrzejewski-Szmek from comment #12)
> I can reproduce the same error easily on a F31 installation, and a clean F32
> server install:
> $ sudo dnf install eclipse-jgit
> Last metadata expiration check: 2:26:12 ago on Thu Sep 12 09:17:37 2019.
> Error: 
>  Problem: conflicting requests
>   - nothing provides jgit = 5.3.0-5.fc31 needed by
> eclipse-jgit-5.3.0-5.fc31.noarch
> (try to add '--skip-broken' to skip uninstallable packages)
> 
> There might be some complex underlying issues, but I think this is for the
> maintainers to figure out.
> From the POV of users (or packages who are not familiar with this particular
> package), a report like
> this should be enough. It's an obvious bug (breaks upgrade path) and
> reproduction is trivial.


There are severe problems with MBS that has prevented me from publishing the Eclipse module sooner. Apologies for the inconvenience.

Comment 15 Fedora Update System 2019-09-24 01:42:14 UTC
eclipse-2019_06-3120190902131726.efdece7d has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.