Bug 17352 - Hostname settings
Hostname settings
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-08 06:24 EDT by Need Real Name
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-08 14:28:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-09-08 06:24:06 EDT
After setting hostname and network definitions, the resulting /etc/hosts is
strange.

Example :
during installation process, I set the hostname to : myhost.mydomain
Next I set for my Ethernet adaptator : IP 10.1.1.1 NetMask : 255.0.0.0

The resulting /etc/hosts is :
# --- /etc/hosts begin ---
127.0.0.1		localhost.localdomain	localhost		myhost.mydomain 
# --- /etc/host end

I think it should be better like this :
# --- /etc/hosts begin ---
127.0.0.1		localhost.localdomain	localhost
10.1.1.1		myhost.mydomain		myhost
# --- /etc/hosts end ---

These are the settings I use now. I fund this probleme when trying to
connect client Corba App to a Corba server running on a distant machine.
The IOR created by Corba server was containing localhost.localdomain as
server Id so the distant client couldn't connect via this IOR. This has
appended with to differents ORBs (ORBit, omniOrb). With new hosts settings
all is running well.

linuxconf doesn't seem to be affected by this problem. 
I Didn't  tried this to other RedHat version than 6.1 (Cartman).


Kind Regards


Sebastien Devaux
ACCOM Multimedia
45 rue St Sebastien
75011 Paris
FRANCE

sde@accom.fr
Comment 1 Michael Fulbright 2000-09-08 14:28:43 EDT
We tried to improve this behavior in 6.2. There are lots of ways to create the
/etc/hosts file (so that
laptops which are not always connected to a network work ok, for example), and
sometimes it will require
menually changing /etc/hosts to get it right for a particular situation.

Note You need to log in before you can comment on or make changes to this bug.