Bug 1735313 - grass: FTBFS in Fedora rawhide/f31
Summary: grass: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grass
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: markusN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1751501 (view as bug list)
Depends On: 1629793
Blocks: F31FTBFS F31_PY2REMOVAL 1732841
TreeView+ depends on / blocked
 
Reported: 2019-07-31 19:30 UTC by Fedora Release Engineering
Modified: 2019-09-18 00:04 UTC (History)
7 users (show)

Fixed In Version: grass-7.8.0-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-18 00:04:45 UTC
Type: ---


Attachments (Terms of Use)
build.log (1.18 KB, text/plain)
2019-07-31 19:30 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-07-31 19:30 UTC, Fedora Release Engineering
no flags Details
state.log (467 bytes, text/plain)
2019-07-31 19:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-07-31 19:30:35 UTC
grass failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36633799


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix grass at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
grass will be orphaned. Before branching of Fedora 32,
grass will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-07-31 19:30:38 UTC
Created attachment 1596421 [details]
build.log

Comment 2 Fedora Release Engineering 2019-07-31 19:30:40 UTC
Created attachment 1596422 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-07-31 19:30:47 UTC
Created attachment 1596423 [details]
state.log

Comment 4 Ben Cotton 2019-08-13 16:47:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 markusN 2019-08-13 22:13:42 UTC
FYI: Just tagged GRASS GIS 7.8.0RC1 which offers Python 3 support:

https://github.com/OSGeo/grass/releases/tag/grass_7_8_0RC1

Comment 6 markusN 2019-09-12 08:00:15 UTC
The final GRASS GIS 7.8.0 with Python 3 support has been published:

https://github.com/OSGeo/grass/releases/tag/7.8.0

I am currently trying to prepare the new RPM (see also bug #1739908)

Comment 7 markusN 2019-09-12 08:02:06 UTC
*** Bug 1751501 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2019-09-15 14:00:15 UTC
FEDORA-2019-bbaea978c7 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-bbaea978c7

Comment 9 Lumír Balhar 2019-09-15 14:13:20 UTC
The latest build seems to not depend on Python 2 anymore. Thank you!

Comment 10 markusN 2019-09-15 14:25:50 UTC
(In reply to Lumír Balhar from comment #9)
> The latest build seems to not depend on Python 2 anymore. Thank you!

Yes, we have finally Python 3 support in GRASS GIS 7.8+

Comment 11 Fedora Update System 2019-09-16 02:05:16 UTC
grass-7.8.0-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-bbaea978c7

Comment 12 Fedora Update System 2019-09-18 00:04:45 UTC
grass-7.8.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.