Bug 1735361 - sys.puts is not a function
Summary: sys.puts is not a function
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs-ronn
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1735015
TreeView+ depends on / blocked
 
Reported: 2019-07-31 20:00 UTC by Stuart D Gathman
Modified: 2020-05-30 03:51 UTC (History)
2 users (show)

Fixed In Version: nodejs-ronn-0.4.0-16.fc32 nodejs-ronn-0.4.0-16.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-30 01:53:52 UTC
Type: Bug


Attachments (Terms of Use)
cjdns-online.md (1003 bytes, text/plain)
2019-07-31 20:12 UTC, Stuart D Gathman
no flags Details
patch ronn to stop using deprecated util.puts and util.debug (958 bytes, patch)
2019-08-03 23:08 UTC, Stuart D Gathman
no flags Details | Diff

Description Stuart D Gathman 2019-07-31 20:00:57 UTC
Description of problem:
Does not convert markdown to nroff

Version-Release number of selected component (if applicable):
nodejs-ronn-0.4.0-13.fc30.noarch

How reproducible:
always

Steps to Reproduce:
1. build cjdns for f31/rawhide at 9c6fb6c6d91bae6e8e063c07f49d3f96006b5c61

Actual results:
+ ronn-nodejs cjdns-online.md
/usr/lib/node_modules/ronn/bin/ronn.js:109
			if (fRoff) sys.puts(fRoff);
			               ^

TypeError: sys.puts is not a function
    at render (/usr/lib/node_modules/ronn/bin/ronn.js:109:19)
    at Object.<anonymous> (/usr/lib/node_modules/ronn/bin/ronn.js:62:2)
    at Module._compile (internal/modules/cjs/loader.js:776:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:787:10)
    at Module.load (internal/modules/cjs/loader.js:643:32)
    at Function.Module._load (internal/modules/cjs/loader.js:556:12)
    at Function.Module.runMain (internal/modules/cjs/loader.js:839:10)
    at internal/main/run_main_module.js:17:11


Expected results:
nroff output

Additional info:

Comment 1 Stuart D Gathman 2019-07-31 20:12:20 UTC
Created attachment 1596551 [details]
cjdns-online.md

Attaching the md file that it failed on so you can test without actually building cjdns.

Comment 2 Stuart D Gathman 2019-08-03 19:58:20 UTC
Looks like nodejs-12 took away the util.puts().  That is used as sys.puts() for stderr.  I'm sure there is a simple replacement, but I'm not up on node.

Comment 3 Stuart D Gathman 2019-08-03 20:02:46 UTC
Even in nodejs-10 sys.puts() is deprecated.  Says use console.log() instead.  That sounds like a search and replace.

Comment 4 Stuart D Gathman 2019-08-03 21:36:59 UTC
The github page says the project has been moved to marked-man.  marked-man has a single dependency: marked, which is supplied by Fedora.

Comment 5 Stuart D Gathman 2019-08-03 22:20:44 UTC
A patch can make it work. Change:

var sys = require('sys');

to:

var console = require('console');
var sys = { 'puts': console.log, 'debug': console.error };

In bin/ronn.js and lib/ronn.js

Comment 6 Stuart D Gathman 2019-08-03 23:08:47 UTC
Created attachment 1600215 [details]
patch ronn to stop using deprecated util.puts and util.debug

I worked around the problem for now by making a local copy of ronn in cjdns build directory, and applying the patch.

Comment 7 Ben Cotton 2019-08-13 17:08:26 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 8 Ben Cotton 2019-08-13 18:34:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 9 Stuart D Gathman 2019-12-06 20:07:07 UTC
I submitted a PR to rpms/nodejs-ronn

Comment 10 Fedora Update System 2020-05-21 03:38:54 UTC
FEDORA-2020-e25557eb2f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2020-e25557eb2f

Comment 11 Fedora Update System 2020-05-21 03:38:55 UTC
FEDORA-2020-4ca6565ae6 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-4ca6565ae6

Comment 12 Fedora Update System 2020-05-21 03:38:55 UTC
FEDORA-2020-874c8d3f48 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-874c8d3f48

Comment 13 Fedora Update System 2020-05-22 03:02:07 UTC
FEDORA-2020-4ca6565ae6 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-4ca6565ae6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-4ca6565ae6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-05-22 04:23:41 UTC
FEDORA-2020-874c8d3f48 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-874c8d3f48`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-874c8d3f48

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Fedora Update System 2020-05-22 04:54:30 UTC
FEDORA-2020-e25557eb2f has been pushed to the Fedora 30 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-e25557eb2f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e25557eb2f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-05-30 01:53:52 UTC
FEDORA-2020-874c8d3f48 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2020-05-30 03:51:06 UTC
FEDORA-2020-4ca6565ae6 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.