Bug 173541 - xterm builds without freetype support if xft-config is not found, even though freetype-config is available
Summary: xterm builds without freetype support if xft-config is not found, even though...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-18 00:33 UTC by Nalin Dahyabhai
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 16:42:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to discard the cached result before checking if freetype-config is available (912 bytes, patch)
2005-11-18 00:33 UTC, Nalin Dahyabhai
no flags Details | Diff

Description Nalin Dahyabhai 2005-11-18 00:33:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):
207-1

How reproducible:
Always

Steps to Reproduce:
1. Run "xterm -fa Monospace -fs 10"
  
Actual results:
You get an unrecognized argument error.

Expected results:
Xterm starts up.

Additional info:
The configure test for freetype-config fails because the previous test for
xft-config fails:
        checking if you want to use FreeType library... yes
        checking for xft-config... none
        checking for freetype-config... (cached) no

Comment 1 Nalin Dahyabhai 2005-11-18 00:33:12 UTC
Created attachment 121212 [details]
patch to discard the cached result before checking if freetype-config is available

Comment 2 Mike A. Harris 2005-11-18 01:05:03 UTC
xft-config has been deprecated for about 2 years or so, and Xft has shipped
pkg-config *.pc files.  xft-config now no longer exists in modular X, and
applications using libXft must now transition to using pkg-config in order
to build properly.

Example usage for fixing xterm:

pts/1 mharris@fc4i386:~/rpmbuild/SRPMS$ pkg-config xft --libs
-lXft -lfreetype -lz -lXrender -lX11 -ldl -lfontconfig
pts/1 mharris@fc4i386:~/rpmbuild/SRPMS$ pkg-config xft --cflags
-I/usr/include/freetype2


Comment 3 Jason Vas Dias 2005-11-18 18:15:01 UTC
Yes, this was fixed with xterm-207-2 (though not as portably as with your
suggestion). I've now patched xterm's configure to use pkg-config instead of 
looking for xft-config / freetype-config with xterm-207-4 . It would have been
nice to be able to patch configure.in, but configure is generated by a 
customized autoconf used only by the upstream maintainer. I've sent the
patch upstream, so hopefully it will be in the next release. Thanks!





Note You need to log in before you can comment on or make changes to this bug.