Bug 1735520 - the search metrics textarea is not auto fit for the alert rule expression
Summary: the search metrics textarea is not auto fit for the alert rule expression
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Andrew Pickering
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-01 03:31 UTC by Junqi Zhao
Modified: 2019-10-16 06:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:15 UTC
Target Upstream Version:


Attachments (Terms of Use)
query browser page (57.02 KB, image/png)
2019-08-01 03:31 UTC, Junqi Zhao
no flags Details
metrics in firefox (47.69 KB, image/png)
2019-08-01 08:00 UTC, Junqi Zhao
no flags Details
metrics in chrome (57.02 KB, image/png)
2019-08-01 08:01 UTC, Junqi Zhao
no flags Details
firefox - AlertmanagerConfigInconsistent (78.23 KB, image/png)
2019-09-02 01:41 UTC, Junqi Zhao
no flags Details
chrome - AlertmanagerConfigInconsistent (73.63 KB, image/png)
2019-09-02 01:41 UTC, Junqi Zhao
no flags Details
the third line can not be viewed clearly in firefox (70.92 KB, image/png)
2019-09-03 02:04 UTC, Junqi Zhao
no flags Details
the first line can not be viewed clearly in chrome (70.83 KB, image/png)
2019-09-03 02:05 UTC, Junqi Zhao
no flags Details
the third line can not be viewed clearly in firefox (70.44 KB, image/png)
2019-09-03 02:08 UTC, Junqi Zhao
no flags Details
the first line can not be viewed clearly in chrome (80.66 KB, image/png)
2019-09-03 02:08 UTC, Junqi Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 2525 0 None None None 2019-08-29 03:27:18 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:31 UTC

Description Junqi Zhao 2019-08-01 03:31:21 UTC
Created attachment 1596855 [details]
query browser page

Description of problem:
find the AlertmanagerConfigInconsistent alert in "Monitoring -> Alerting", and go to the alert rule detail page, Expression is:

count_values by(service) ("config_hash", alertmanager_config_hash{job="alertmanager-main",namespace="openshift-monitoring"}) / on(service) group_left() label_replace(prometheus_operator_spec_replicas{controller="alertmanager",job="prometheus-operator",namespace="openshift-monitoring"}, "service", "alertmanager-$1", "name", "(.*)") != 1

Click the link, it navigates to Query Browser, see the attached picture, at the first glance, we would think the expression is:
"(.*)") != 1

need to drag the textarea to enlarge, and then can see the full expression

Maybe we should not add link the alert rule Expression, 4.1 does not have this link

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-31-162901

How reproducible:
Alwasy

Steps to Reproduce:
1. See the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Junqi Zhao 2019-08-01 08:00:12 UTC
Created attachment 1596867 [details]
metrics in firefox

Comment 3 Junqi Zhao 2019-08-01 08:01:10 UTC
Created attachment 1596868 [details]
metrics in chrome

Comment 5 Junqi Zhao 2019-08-30 05:09:08 UTC
fix is not in the latest OCP build:4.2.0-0.nightly-2019-08-29-170426, will wait for new build

Comment 7 Junqi Zhao 2019-09-02 01:41:39 UTC
Created attachment 1610604 [details]
firefox - AlertmanagerConfigInconsistent

Comment 8 Junqi Zhao 2019-09-02 01:41:59 UTC
Created attachment 1610605 [details]
chrome - AlertmanagerConfigInconsistent

Comment 11 Junqi Zhao 2019-09-03 01:59:52 UTC
much better with 4.2.0-0.nightly-2019-09-02-172410
but the third line can not be viewed clearly in firefox, the third line can not be viewed clearly in chrome.
It may be not good

Comment 12 Junqi Zhao 2019-09-03 02:00:47 UTC
(In reply to Junqi Zhao from comment #11)
> much better with 4.2.0-0.nightly-2019-09-02-172410
> but the third line can not be viewed clearly in firefox, the third line can
> not be viewed clearly in chrome.
> It may be not good

correction:
but the third line can not be viewed clearly in firefox, the first line can not be viewed clearly in chrome.

Comment 13 Junqi Zhao 2019-09-03 02:04:44 UTC
Created attachment 1611016 [details]
the third line can not be viewed clearly in firefox

Comment 14 Junqi Zhao 2019-09-03 02:05:07 UTC
Created attachment 1611017 [details]
the first line can not be viewed clearly in chrome

Comment 15 Junqi Zhao 2019-09-03 02:08:30 UTC
Created attachment 1611018 [details]
the third line can not be viewed clearly in firefox

Comment 16 Junqi Zhao 2019-09-03 02:08:51 UTC
Created attachment 1611019 [details]
the first line can not be viewed clearly in chrome

Comment 17 Junqi Zhao 2019-09-03 02:19:58 UTC
move back to Assigned

Comment 18 Andrew Pickering 2019-09-03 11:37:27 UTC
I think the textarea size is acceptable. The current default should be enough for the large majority of queries and it is always possible to manually expand it.

Also, the difference between Chrome and Firefox (whether the textarea scrolls to the top or bottom) seems OK since either behavior should be equally good.

Comment 20 Junqi Zhao 2019-09-04 02:21:18 UTC
move to VERIFIED as per Comment 18

Comment 21 errata-xmlrpc 2019-10-16 06:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.