Bug 173563 - filelist cleanup: drop unnecessary files, eliminate duplicates
filelist cleanup: drop unnecessary files, eliminate duplicates
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-17 22:25 EST by Marius Feraru
Modified: 2008-02-27 07:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-27 07:12:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
drop useless files, eliminate duplicates (2.64 KB, patch)
2005-11-17 22:27 EST, Marius Feraru
no flags Details | Diff

  None (edit)
Description Marius Feraru 2005-11-17 22:25:19 EST
Drop more cruft that comes with the usual installation (Attribute/Handlers/demo,
CGI/eg, TODOs, READMEs, etc) and let DBM_Filter live (as we just want NDBM* out).

(patch for 5.8.7-0.7.fc5 spec attached)
Comment 1 Marius Feraru 2005-11-17 22:27:17 EST
Created attachment 121216 [details]
drop useless files, eliminate duplicates
Comment 2 Jason Vas Dias 2005-11-18 12:56:03 EST
OK, I'll put in most of these changes with the next perl-5.8.7-0.8.fc5 release -
I'm still working on more upstream backports and a fix for bug 172792 .
I disagree that README files, changelogs, and examples are "useless" - I 
think they should stay in.
Comment 3 Ville Skyttä 2005-11-19 03:54:55 EST
It would be nicer to have the READMEs etc in the doc dir instead of being  
scattered somewhere below /usr/lib/perl5/x.x.x though.  
Comment 4 Marius Feraru 2005-11-19 09:17:13 EST
Indeed, "useless" is not an appropriate word for the matter, but the issue is
valid - those files should really disappear _from /usr/lib/*_
I think it's better to not have them at all rather than scattered wherever
on the filesystem.
As Ville said, if you want to keep them, move them in %docdir. Farther, if
you do that, than place those demo files there too, they should be useful too :)

OTOH, do you remember any redhat/fedora perl package that includes
changelogs? They don't even include the license :|

If you want to fix this, then add this line to the %files list:
    %doc Artistic AUTHORS Changes* Copying README

And this to %install or something:
    # wanna have them, but compressed though ;-)
    %{__gzip} Changes*
Comment 5 Robin Norwood 2007-10-16 14:56:39 EDT
Applied changes for comment #4 in rawhide (perl-5.8.8-29.fc8

Not perfect yet, but better.
Comment 6 Marcela Mašláňová 2008-02-27 07:12:29 EST
Nothing terribly wrong in spec file for F-8. F-9 spec file is much better so I'm
closing it.

Note You need to log in before you can comment on or make changes to this bug.