Bug 1735700 - keyboard.js: JS error this._rect is undefined
Summary: keyboard.js: JS error this._rect is undefined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.6
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: 7.8
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-01 09:53 UTC by Deepu K S
Modified: 2021-05-21 10:34 UTC (History)
8 users (show)

Fixed In Version: gnome-shell-3.28.3-27.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-29 20:21:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell issues 464 0 None None None 2019-08-01 09:57:04 UTC
Red Hat Product Errata RHBA-2020:3987 0 None None None 2020-09-29 20:22:25 UTC

Description Deepu K S 2019-08-01 09:53:06 UTC
Description of problem:
Maximize/Minimize window by double-clicking gives a JS ERROR in system logs.

Jul 31 16:01:07 example.redhat.com gnome-shell[25096]: JS ERROR: Exception in callback for signal: position-changed: TypeError: this._rect is undefined

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 7.6
gnome-shell-3.28.3-8.el7_6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal
2. Double-click on titlebar to maximize.
3. # journalctl --this-boot

Actual results:
Jul 31 16:01:07 vm251-241.gsslab.pnq2.redhat.com gnome-shell[25096]: JS ERROR: Exception in callback for signal: position-changed: TypeError: this._rect is undefined
                                                                     getCurrentRect@resource:///org/gnome/shell/ui/keyboard.js:553:22
                                                                     wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                                     _onFocusPositionChanged@resource:///org/gnome/shell/ui/keyboard.js:635:20
                                                                     wrapper@resource:///org/gnome/gjs/modules/_legacy.js:82:22
                                                                     _emit@resource:///org/gnome/gjs/modules/signals.js:128:27
                                                                     _setCurrentWindow/this._currentWindowPositionId<@resource:///org/gnome/shell/ui/keyboard.js:534:21

Expected results:
No JS Errors.

Additional info:
Upstream BZ : https://gitlab.gnome.org/GNOME/gnome-shell/issues/464

Comment 7 Michael Boisvert 2020-06-03 14:41:29 UTC
I was able to reproduce the error on gnome-shell-3.28.3-25.el7 and on gnome-shell-3.28.3-27.el7 the error in the journal was no longer present after a reboot.

Comment 12 errata-xmlrpc 2020-09-29 20:21:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (GNOME bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3987


Note You need to log in before you can comment on or make changes to this bug.