Bug 1735710 - [sriov]Old network-attachment-definitions did not be deleted after update the networkNamespace
Summary: [sriov]Old network-attachment-definitions did not be deleted after update the...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-01 10:01 UTC by zhaozhanqi
Modified: 2019-10-16 06:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:31 UTC

Description zhaozhanqi 2019-08-01 10:01:50 UTC
Description of problem:
when update the networkNamespace of CR SriovNetwork, the networkadditiondefination of old namespace did not be removed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. set sriov env and install the sriov operator
2. create SriovNetwork CR
3. update the networkNamespace to another namespace z2 from z1
4. check the old networkadditiondefination still exist 
Actual results:

step 4
the old networkadditiondefination of z1 still exist

Expected results:

1. should be removed the old networkadditiondefination 
or
2. do not allow edit the networkNamespace

Additional info:

Comment 3 zhaozhanqi 2019-08-12 07:00:00 UTC
Verified this bug on with sirov operator image: quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.2.0-201908090219-ose-sriov-network-operator

Comment 4 errata-xmlrpc 2019-10-16 06:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.