Bug 1735748 - ocf:heartbeat:CTDB is blocked by selinux
Summary: ocf:heartbeat:CTDB is blocked by selinux
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: selinux-policy
Version: 8.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Zdenek Pytela
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks: 1732867
TreeView+ depends on / blocked
 
Reported: 2019-08-01 11:48 UTC by Martin Juricek
Modified: 2020-11-04 01:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-04 01:55:53 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4528 0 None None None 2020-11-04 01:56:19 UTC

Comment 2 Lukas Vrabec 2019-08-01 12:25:32 UTC
Hi, 

Did you disabled SELinux on the system and then enabled it again? It looks that system is mislabeled. 

Could yo plase run:

# restorecon -Rv /

and then tray to reproduce the issue again? 

Thanks,
Lukas.

Comment 4 Lukas Vrabec 2019-08-01 14:54:40 UTC
commit d318c9913c1805c6815a44b2e477a86aa7c9eb68 (HEAD -> rawhide)
Author: Lukas Vrabec <lvrabec@redhat.com>
Date:   Thu Aug 1 16:51:58 2019 +0200

    Update ctdbd_t policy
    
    Allow ctdbd processes labeled as ctdbd_t to mmap files labeled as
    ctdbd_var_t and ctdbd_var_run_t
    Resolves: rhbz#1735748


Fixes from Fedora.

Comment 16 errata-xmlrpc 2020-11-04 01:55:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (selinux-policy bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4528


Note You need to log in before you can comment on or make changes to this bug.