Bug 173578 - RFE: Support virtual wifi devices in madwifi driver
RFE: Support virtual wifi devices in madwifi driver
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 04:51 EST by Mephisto
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:51:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2005-11-18 04:51:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051103 Fedora/1.5-0.5.0.rc1 Firefox/1.5

Description of problem:
I have an atheros based wifi card, which uses the madwifi driver, and the card itself works fine, but there are 2 types of drivers for it: the old one, which supports only 1 logical wifi device per card (ath0), and the new one, which creates a wifi0 device where you can create virtual wlan devices (ath0, ath1, etc). This enables the user to use mutliple access points at once, or be AP and client at the same time. These virtual devices are created with the spplied wlanconfig utility.
But the system-config-network applet does not recognise the athX devices created with wlanconfig. It only shows the wifi0 device as an ethernet device, and no wireless connections can be configured. The athX devices don't show up at all.
I'd like to see support for these virtual devices in a future version of the applet, since i consider this a must-have for anyone that is not a linux guru. Of course they can be configured on commandline, but a lot of people probably dont know how to do this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install new madwifi driver
2. Try to configure it using system-config-network
3.
  

Additional info:
Comment 1 Harald Hoyer 2006-01-24 10:44:48 EST
it should really recognize ath0... strange... it uses iwlib (like iwconfig) to
determine wlan interfaces.
Comment 2 Kyle Pablo 2006-03-30 12:37:44 EST
Sane problem here. It recognizes it as an ethernet device, thus unable to get to
sct as a wireless device.  
Comment 3 Mephisto 2006-03-31 18:23:02 EST
With the latest version of the madwifi-ng driver, it autocreates an ath0 device
automatically in managed mode. however, it cant switch modes, since the mode has
to be set when creating the device.

@Harald: the original problem wasnt about the ath0. Until recently, there was no
ath0 with madwifi-ng, and had to be created manually with wlanconfig. Now the
device gets created automatically, to better reflect the behaviour of other
drivers, but this doesnt work if you want to use ad-hoc mode, since the device
needs to be re-created.
Comment 4 Kyle Pablo 2006-08-23 13:48:23 EDT
this problem still exist when setting up a wireless nic and madwifi in network
manager.
Comment 5 Kyle Pablo 2006-08-23 13:51:27 EDT
(In reply to comment #4)
> this problem still exist when setting up a wireless nic and madwifi in network
> manager.

this is on FC5 with system-config-network-1.3.30-2.1 on kernel-2.6.17-1.2174_FC5

Note You need to log in before you can comment on or make changes to this bug.