Bug 173595 - os.path.realpath can't handle symlink loops
os.path.realpath can't handle symlink loops
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: Patch
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2005-11-18 10:18 EST by Göran Uddeborg
Modified: 2013-04-12 13:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0468
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 14:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
python-no-symlink-loop-rhel3-2.patch (2.05 KB, patch)
2005-11-22 04:10 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Göran Uddeborg 2005-11-18 10:18:37 EST
Description of problem:
The problem is described in
https://sourceforge.net/tracker/index.php?func=detail&aid=930024&group_id=5470&atid=105470

Version-Release number of selected component (if applicable):
python-2.2.3-6.1 (RHEL3)
python-2.3.4-14.1 (RHEL4)

How reproducible:
Every time

Steps to Reproduce:
See upstreams report

Additional info:
The problem is fixed in newer releases upstreams.  The reason for this bug
report is that we need this fix in the python in RHEL3 and RHEL4, none of which
has the fix.  In the case of RHEL4, it would probably be enough to upgrade
python to 2.3.5.  For RHEL3, I guess a backport will be necessary.
Comment 1 Bastien Nocera 2005-11-22 04:10:39 EST
Created attachment 121334 [details]
python-no-symlink-loop-rhel3-2.patch

Backported from
http://cvs.sourceforge.net/viewcvs.py/python/python/dist/src/Lib/posixpath.py?rev=1.75&view=log


1)
Revision 1.67  - (view) (download) (as text) (annotate) - [select for diffs]
Sat Jul 10 22:55:13 2004 UTC (16 months, 1 week ago) by bcannon
Branch: MAIN
Changes since 1.66: +30 -6 lines
Diff to previous 1.66

posixpath.realpath() now detects symlink loops and returns the path just before

the loop starts.

Closes bug #930024.  Thanks AM Kuchling.

2)
Revision 1.71  - (view) (download) (as text) (annotate) - [select for diffs]
Sat Aug 14 15:01:53 2004 UTC (15 months, 1 week ago) by jlgijsbers
Branch: MAIN
Changes since 1.70: +9 -7 lines
Diff to previous 1.70

bug #990669: os.path.realpath() will resolve symlinks before normalizing the
path, as normalizing the path may alter the meaning of the path if it contains
symlinks.

Also add tests for infinite symlink loops and parent symlinks that need to be
resolved.

And 3)
Revision 1.74  - (view) (download) (as text) (annotate) - [select for diffs]
Fri Jun 3 14:24:43 2005 UTC (5 months, 2 weeks ago) by birkenfeld
Branch: MAIN
Changes since 1.73: +1 -1 lines
Diff to previous 1.73

Bug #1213894: os.path.realpath didn't resolve symlinks that were the first
component of the path.
Comment 2 Steve 2006-04-12 09:14:04 EDT
The client is asking for an update on this issue and has asked why this was not
fixed in the latest update release.
Comment 5 Jeremy Katz 2006-12-21 18:17:57 EST
Committed the patch and building as python-2.2.3-6.6
Comment 11 Red Hat Bugzilla 2007-06-11 14:46:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0468.html

Note You need to log in before you can comment on or make changes to this bug.