Bug 173612 - RHEL3 U6 release notes mention a "32-bit Compatibility Layer disc" which doesn't exist for RHEL 3
RHEL3 U6 release notes mention a "32-bit Compatibility Layer disc" which does...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-release-as (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Fitzsimon
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-18 11:59 EST by Chris Williams
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:50:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Williams 2005-11-18 11:59:45 EST
RHEL3 U6 release notes mention a "32-bit Compatibility Layer disc" which doesn't
exist for RHEL 3. It exists for RHEL 4, but not RHEL 3. In RHEL 4 ia64, the x86
packages are on a seprate disk. In RHEL 3 ia64, these packages are on the
regular installation disks.

http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/release-notes/as-itanium/RELEASE-NOTES-U6-itanium-en.html

<snip>

In addition, a set of 32-bit libraries and applications are provided on a
separate 32-bit Compatibility Layer disc. The IA-32 Execution Layer and 32-bit
compatibility packages together provide a runtime environment for 32-bit
applications on the 64-bit native distribution.

To install the IA-32 Execution Layer and required 32-bit compatibility packages,
follow these steps:

1. During the installation of Red Hat Enterprise Linux 3 for the Intel Itanium2
Architecture, make sure to exclude the compatibility arch packages by clearing
the Compatibility Arch Support checkbox in the System category and the
Compatibility Arch Development Support checkbox in the Development category.
2. Insert the Red Hat Enterprise Linux 3 Extras CD, which contains the ia32el
package.
3. After the system has mounted the CD, change to the directory containing the
Extras packages. For example: 

cd /mnt/cdrom/RedHat/RPMS/


4. Install the ia32el package:

rpm -Uvh ia32el-<version>.ia64.rpm

where <version> is the version of the ia32el package to be installed.


5. Eject the Extras CD:


eject /mnt/cdrom



6. Install the compatibility layer libraries by running system-config-packages
and clicking the checkboxes for Compatibility Arch Support in the Systems
category and Compatibility Arch Development Support in the Development category.
Follow the on-screen prompts carefully, as the instructions specify the Red Hat
Enterprise Linux 3 disc to insert to install the compatibility layer library
packages.


7. To verify the installation of the 32-bit compatibility layer and libraries
after installation, check that the /emul directory has been created and contains
files. 

</snip>


It looks like step 6 is correct, so the crux of the matter is the mention of the
 "32-bit Compatibility Layer disc"
Comment 1 Michael Hideo 2006-08-02 23:08:23 EDT
Don, assigning to you. Please edit the RHEL3U6 releaselnotes  and post a new
version. Alert Andy once the build is complete and he will put it on .com.
Comment 2 Don Domingo 2006-08-03 00:13:44 EDT
have revised RHEL3U6 master file as specified herein. this file --
RELEASE-NOTES-U6-master-en.xml -- is in the /readmes/3.0E/ directory of the
/docs-stuff/ module.

am passing on to Andy for final build to .com, as instructed. 

Comment 3 Michael Hideo 2007-06-06 00:43:50 EDT
Adding 'cc ecs-dev-list@redhat.com for tracking
Comment 4 RHEL Product and Program Management 2007-10-19 14:50:48 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.