Bug 1736585 - resteasy: FTBFS in Fedora rawhide/f31
Summary: resteasy: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: resteasy
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alex Scheel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FTBFS 1732841 1751976 1752551
TreeView+ depends on / blocked
 
Reported: 2019-08-01 19:02 UTC by Fedora Release Engineering
Modified: 2019-10-21 18:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-21 18:53:37 UTC


Attachments (Terms of Use)
build.log (1.19 KB, text/plain)
2019-08-01 19:02 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-08-01 19:02 UTC, Fedora Release Engineering
no flags Details
state.log (477 bytes, text/plain)
2019-08-01 19:02 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-08-01 19:02:51 UTC
resteasy failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36637427


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix resteasy at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
resteasy will be orphaned. Before branching of Fedora 32,
resteasy will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-08-01 19:02:54 UTC
Created attachment 1599013 [details]
build.log

Comment 2 Fedora Release Engineering 2019-08-01 19:02:56 UTC
Created attachment 1599014 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-08-01 19:02:57 UTC
Created attachment 1599015 [details]
state.log

Comment 4 Ben Cotton 2019-08-13 16:55:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 5 Ben Cotton 2019-08-13 17:58:36 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 6 Alex Scheel 2019-09-16 19:15:31 UTC
*** Bug 1752551 has been marked as a duplicate of this bug. ***

Comment 7 Alex Scheel 2019-09-16 19:26:36 UTC
*** Bug 1752551 has been marked as a duplicate of this bug. ***

Comment 8 Dinesh Prasanth 2019-10-21 18:53:37 UTC
The resteasy is now buildable: https://koji.fedoraproject.org/koji/packageinfo?packageID=13615

We have placed resteasy on bodhi. 

F31: https://bodhi.fedoraproject.org/updates/FEDORA-2019-636c9ead78
F32/rawhide: https://bodhi.fedoraproject.org/updates/FEDORA-2019-9cf340d96e

So, closing this bug as CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.