Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 173675 - Review Request: xfce4-xmms-plugin
Review Request: xfce4-xmms-plugin
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Greg DeKoenigsberg
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-11-18 16:11 EST by Christoph Wickert
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-15 15:03:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2005-11-18 16:11:26 EST
Spec Name or Url: 
SRPM Name or Url: 
Control XMMS from the Xfce panel.

rpmlint clan
license BSD included
Comment 1 Luya Tshimbalanga 2005-11-30 04:30:44 EST
spec looks good but built failed on rawhide on this line:

checking for xfce4-panel-1.0 >= 4.0.0... Package libxfcegui4-1.0 was not found
in the pkg-config search path. Perhaps you should add the directory containing
`libxfcegui4-1.0.pc' to the PKG_CONFIG_PATH environment variable Package
'libxfcegui4-1.0', required by 'xfce4-panel', not found
configure: error: Library requirements (xfce4-panel-1.0 >= 4.0.0) not met;
consider adjusting the PKG_CONFIG_PATH environment variable if your libraries
are in a nonstandard prefix so pkg-config can find them.
error: Bad exit status from /var/tmp/rpm-tmp.68902 (%build)

- Add libxfcegui4-1.0 as requirement
Comment 3 Luya Tshimbalanga 2005-12-02 03:41:01 EST

I completed the review of this packages. It succesfully passed and complied to
the package guideline http://fedoraproject.org/wiki/PackagingGuidelines. The
package is now set to FE-ACCEPTED.
Comment 4 Christoph Wickert 2005-12-15 15:03:52 EST
Thanks for the review. Package will be released for Core 4 and devel soon. Won't
build on Core 3 because pango is out of date there.
Comment 5 Luya Tshimbalanga 2005-12-16 05:07:59 EST
Perhaps by lowering pango version on the spec file this package will be built
for FC3. 
Comment 6 Christoph Wickert 2005-12-16 07:52:09 EST
(In reply to comment #5)
> Perhaps by lowering pango version on the spec file this package will be built
> for FC3. 

Nope, the version is not in the spec file but in configure.ac. This plugin
_needs_ pango >= 1.8.0 while Core 3 comes with 1.6.0.

Note You need to log in before you can comment on or make changes to this bug.