Bug 1736812 - openshift-controller-manager-operator pod is using alpha api
Summary: openshift-controller-manager-operator pod is using alpha api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.0
Assignee: Stefan Schimanski
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 06:21 UTC by Liang Xia
Modified: 2019-10-16 06:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-openshift-controller-manager-operator pull 112 0 None closed Bug 1736812: fix apiVersion for operator config 2020-08-28 06:21:24 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:39 UTC

Description Liang Xia 2019-08-02 06:21:03 UTC
Description of problem:
openshift-controller-manager-operator pod is using alpha api


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-28-222114
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"1cca013db", GitTreeState:"clean", BuildDate:"2019-08-01T18:56:59Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"14+", GitVersion:"v1.14.0+1682e38", GitCommit:"1682e38", GitTreeState:"clean", BuildDate:"2019-07-28T20:08:40Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
OpenShift Version: 4.2.0-0.nightly-2019-07-28-222114


How reproducible:
Always

Steps to Reproduce:
1.oc project openshift-controller-manager-operator
2.oc get pods
3.oc rsh $above_pod
4.find . -name config.yaml -exec cat {} \;

Actual results:
apiVersion: operator.openshift.io/v1alpha1
kind: GenericOperatorConfig


Expected results:
alpha api should not be used for prod cluster.

Additional info:

Comment 3 wewang 2019-08-06 05:29:25 UTC
Verified in
4.2.0-0.nightly-2019-08-05-223032

[wewang@Desktop Downloads]$ oc rsh openshift-controller-manager-operator-7946dc896f-rjd92
sh-4.2# find -name config.yaml -exec cat {} \;
apiVersion: operator.openshift.io/v1
kind: GenericOperatorConfig

Comment 4 errata-xmlrpc 2019-10-16 06:34:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.