Bug 1736817 - It takes a long time to display the `OperatorHub` section
Summary: It takes a long time to display the `OperatorHub` section
Keywords:
Status: CLOSED DUPLICATE of bug 1727800
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 06:31 UTC by Jian Zhang
Modified: 2019-08-07 14:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 14:23:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jian Zhang 2019-08-02 06:31:33 UTC
Description of problem:
I'd like to report this performance issue since it's really not a good experience for users, especially installing multi-operators. It takes an average of 1min30s to display the `OperatorHub` section. 

Version-Release number of selected component (if applicable):
Cluster version is 4.2.0-0.nightly-2019-07-31-162901
mac:~ jianzhang$ oc exec catalog-operator-7d78f889bf-85vlx -- olm --version
OLM version: 0.11.0
git commit: d2209c409b35f1db4669c474044decc6995f624d

How reproducible:
always

Steps to Reproduce:
1. Install OCP 4.2.
2. Install an operator on the Web console. And then, switch to the `Installed Operators` section automatically.
3. Click `OperatorHub` section to install another operator.

Actual results:
The users have to take about 1min30s to wait the `OperatorHub` to display.
https://user-images.githubusercontent.com/15416633/62348866-a868aa00-b530-11e9-926e-2cfb5f2b7efe.png

Expected results:
The `OperatorHub` section should take little time to display for better user experiences.

Additional info:
I know the displaying depends on the PackageServer, so I open this issue in OLM component. Please feel free to transfer it to the Web console team if I'm wrong.

Comment 1 Evan Cordell 2019-08-06 14:24:31 UTC
My understanding is that this is related to the icons we use, which the browser doesn't cache (because they're embedded).

I think you could make an argument either way, but I'm re-targeting to web console to see if there's some solution that can happen there, since we don't have a simple option to remove the embedded icons.

Comment 2 Samuel Padgett 2019-08-07 14:23:22 UTC

*** This bug has been marked as a duplicate of bug 1727800 ***


Note You need to log in before you can comment on or make changes to this bug.