Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1736825 - Diagz logging errors
Summary: Diagz logging errors
Keywords:
Status: CLOSED DUPLICATE of bug 1761930
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 06:47 UTC by Luis Martinho
Modified: 2020-01-31 17:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 17:09:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luis Martinho 2019-08-02 06:47:23 UTC
Hi,

Customer is running OCP v3.11.129 and the diagz are showing the following error.
The bugzzila 
https://bugzilla.redhat.com/show_bug.cgi?id=1676720 and
https://bugzilla.redhat.com/show_bug.cgi?id=1619487
should have had fixed this.


[Note] Running diagnostic: AggregatedLogging
       Description: Check aggregated logging integration for proper configuration

ERROR: [AGL0065 from diagnostic AggregatedLogging@openshift/origin/pkg/oc/cli/admin/diagnostics/diagnostics/cluster/aggregated_logging/diagnostic.go:138]
       Did not find a DeploymentConfig to support component 'curator'

Info:  Did not find a DeploymentConfig to support optional component 'curator-ops'. If you require
       this component, please re-install or update logging and specify the appropriate
       variable to enable it.

Info:  Did not find a DeploymentConfig to support optional component 'es-ops'. If you require
       this component, please re-install or update logging and specify the appropriate
       variable to enable it.

Info:  Did not find a DeploymentConfig to support optional component 'kibana-ops'. If you require
       this component, please re-install or update logging and specify the appropriate
       variable to enable it.

Info:  Did not find a DeploymentConfig to support optional component 'mux'. If you require
       this component, please re-install or update logging and specify the appropriate
       variable to enable it.

ERROR: [AGL0805 from diagnostic AggregatedLogging@openshift/origin/pkg/oc/cli/admin/diagnostics/diagnostics/cluster/aggregated_logging/diagnostic.go:138]
       There was an error while trying to retrieve the CronJobs in project 'openshift-logging': the server could not find the requested resource

Info:  Looked for 'logging-es-ops' among the logging services for the project but did not find it.
       This optional component may not have been specified by logging install options.

Info:  Looked for 'logging-es-ops-cluster' among the logging services for the project but did not find it.
       This optional component may not have been specified by logging install options.

Info:  Looked for 'logging-kibana-ops' among the logging services for the project but did not find it.
       This optional component may not have been specified by logging install options.

Info:  Looked for 'logging-mux' among the logging services for the project but did not find it.
       This optional component may not have been specified by logging install options.

Comment 3 Jeff Cantrill 2020-01-31 17:09:17 UTC

*** This bug has been marked as a duplicate of bug 1761930 ***


Note You need to log in before you can comment on or make changes to this bug.