Bug 1736831 - HP printer which requres proprietary plugin is not working after hplip update
Summary: HP printer which requres proprietary plugin is not working after hplip update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 07:05 UTC by Milos Ivanovic
Modified: 2019-08-02 08:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-02 07:34:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Milos Ivanovic 2019-08-02 07:05:03 UTC
Description of problem:
I have a HP LasterJet M1132 MFP printer/scanner which requires HP proprietary plugin. It works well upon installation using hp-plugin command. However, after each regular update of hplip or (maybe) cups package, it stopps working. Then I have to reinstall the plugin in order to get it working again. 

Version-Release number of selected component (if applicable):
Fedora 30 and (if I remember well) 29, as well. 

How reproducible:
If the printer requires proprietary HP plugin, always.

Steps to Reproduce:
1. Issue "hp-plugin -i"
2. Printer works
3. hplip package updated
4. Printer stops working

Actual results:
The printer should be working after hplip update. If I remember well, it works on Debian/Ubuntu, evena after update. 

Expected results:
The printer should be working upon any package update.

Additional info:

Comment 1 Zdenek Dohnal 2019-08-02 07:34:16 UTC
Hi Milos,

thank you for reporting the issue! Would it be possible to find out which update was it? I have suspicion it was because of rebase to 3.19.6, which needs the same version of plugin as installed hplip - printing fails otherwise due plugin version check.

The check is necessary, because there can be changes in open source project which will require new proprietary libraries from plugin, so it could break printing too. I'm sorry about it, but it is due the issue plugin is not open source and we can not ship it even in rpmfusion...

I added the issue to known problems https://fedoraproject.org/wiki/How_to_debug_printing_problems#Device_which_needs_plugin_does_not_work_after_HPLIP_update

Please check if it was rebase which broke your printing and if it was not, feel free to reopen.

Comment 2 Milos Ivanovic 2019-08-02 07:49:43 UTC
Hi Zdenek,

Thanks on your quick response. Yes, it was an update to hplip-3.19.6-1.fc30. However, I remember the same was happening on very much every update for me since F29. If it happens on next update, I will reopen.

Comment 3 Zdenek Dohnal 2019-08-02 08:30:06 UTC
If it happens, please provide cups and journal (hplip tends to write to journal directly IIRC) logs when you reopen. See https://fedoraproject.org/wiki/How_to_debug_printing_problems .
And I would like to mention that if you use Fedora Silverblue, then you need to run hp-plugin before you want to print and you turned off/restarted your PC before that...


Note You need to log in before you can comment on or make changes to this bug.