Bug 1736846 - openshift-service-catalog-controller-manager-operator pod is using alpha api
Summary: openshift-service-catalog-controller-manager-operator pod is using alpha api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Service Catalog
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Jesus M. Rodriguez
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 07:42 UTC by Liang Xia
Modified: 2019-10-16 06:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-svcat-controller-manager-operator pull 48 0 None closed Bug 1736846: fix apiversion for operator config 2020-09-16 07:33:00 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:39 UTC

Description Liang Xia 2019-08-02 07:42:11 UTC
Description of problem:
openshift-service-catalog-controller-manager-operator pod is using alpha api


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-28-222114
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"1cca013db", GitTreeState:"clean", BuildDate:"2019-08-01T18:56:59Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"14+", GitVersion:"v1.14.0+1682e38", GitCommit:"1682e38", GitTreeState:"clean", BuildDate:"2019-07-28T20:08:40Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
OpenShift Version: 4.2.0-0.nightly-2019-07-28-222114


How reproducible:
Always

Steps to Reproduce:
1.oc project openshift-service-catalog-controller-manager-operator
2.oc get pods
3.oc rsh $above_pod
4.find . -name config.yaml -exec cat {} \;

Actual results:
apiVersion: operator.openshift.io/v1alpha1
kind: GenericOperatorConfig


Expected results:
alpha api should not be used for prod cluster.

Additional info:

Comment 1 Jian Zhang 2019-08-02 08:31:31 UTC
The `apiVersion` of the `ServiceCatalogControllerManager` resource does `v1`, see below.
I closed it as a duplicated of bug 1736843, please feel free to reopen it if any more concerns.

mac:~ jianzhang$ oc get servicecatalogcontrollermanager cluster -o yaml
apiVersion: operator.openshift.io/v1
kind: ServiceCatalogControllerManager
metadata:
  annotations:
    release.openshift.io/create-only: "true"
  creationTimestamp: "2019-08-01T01:45:14Z"
  generation: 1
  name: cluster
  resourceVersion: "7255"
  selfLink: /apis/operator.openshift.io/v1/servicecatalogcontrollermanagers/cluster
  uid: 01dc1c63-b3fe-11e9-bb01-02c0576697c8
spec:
  logLevel: Normal
  managementState: Removed
status:
  conditions:
  - lastTransitionTime: "2019-08-01T01:49:51Z"
    reason: Removed
    status: "True"
    type: Available
  - lastTransitionTime: "2019-08-01T01:49:51Z"
    reason: Removed
    status: "False"
    type: Progressing
  - lastTransitionTime: "2019-08-01T01:49:51Z"
    reason: Removed
    status: "False"
    type: Degraded
  readyReplicas: 0
  version: 4.2.0-0.nightly-2019-07-31-162901

*** This bug has been marked as a duplicate of bug 1736843 ***

Comment 2 Liang Xia 2019-08-02 09:03:03 UTC
Though the issue are quite the same, they are coming from different repositories. We need to fix them separately.

https://github.com/openshift/cluster-svcat-controller-manager-operator/blob/master/manifests/03_configmap.yaml

Comment 5 Jian Zhang 2019-08-06 07:46:49 UTC
Image is not ready for the test, change the status back to MODIFIED.
And, I will verify this bug once my concerns in https://bugzilla.redhat.com/show_bug.cgi?id=1724484#c5 are addressed.

Comment 8 Jian Zhang 2019-08-13 09:00:31 UTC
As @sttts reply in https://coreos.slack.com/archives/CB48XQ4KZ/p1565667523433300
that change was a mistake without consequences. That type is internal only (stored in a configmap not touchable by the user). And we read it without caring about the api version. That's why it did not break.

So for now, both of the `v1alpha1` and `v1` are OK. Will change the version to `v1` from `v1alpha1` on 4.3. https://github.com/openshift/api/blob/master/operator/v1alpha1/register.go#L11-L12 

Anyway, verify this bug first.

mac:~ jianzhang$ oc get pods
NAME                                                              READY   STATUS    RESTARTS   AGE
openshift-service-catalog-controller-manager-operator-78c6fqf8m   1/1     Running   0          5h37m
mac:~ jianzhang$ oc rsh openshift-service-catalog-controller-manager-operator-78c6fqf8m
sh-4.2# find . -name config.yaml 
./run/configmaps/config/..2019_08_13_03_19_16.590720269/config.yaml
./run/configmaps/config/config.yaml
sh-4.2# cat ./run/configmaps/config/..2019_08_13_03_19_16.590720269/config.yaml
apiVersion: operator.openshift.io/v1
kind: GenericOperatorConfig
sh-4.2# cat ./run/configmaps/config/config.yaml
apiVersion: operator.openshift.io/v1
kind: GenericOperatorConfig

version info:
             io.openshift.build.commit.url=https://github.com/openshift/cluster-svcat-controller-manager-operator/commit/6e059d5069366f9ff3383a9ae17cf7c4626cad87
             io.openshift.build.source-location=https://github.com/openshift/cluster-svcat-controller-manager-operator

Cluster version: 4.2.0-0.nightly-2019-08-08-103722

Comment 9 errata-xmlrpc 2019-10-16 06:34:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.