Bug 1736936 - upm: FTBFS in Fedora rawhide/f31
Summary: upm: FTBFS in Fedora rawhide/f31
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: upm
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1773380 (view as bug list)
Depends On: 1721671
Blocks: F31FTBFS F32FTBFS F32FailsToInstall PYTHON38 1732841 PYTHON39
TreeView+ depends on / blocked
 
Reported: 2019-08-02 09:40 UTC by Fedora Release Engineering
Modified: 2020-04-23 18:02 UTC (History)
3 users (show)

Fixed In Version: upm-2.0.0-5.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-23 18:02:31 UTC
Type: ---


Attachments (Terms of Use)
build.log (1.17 KB, text/plain)
2019-08-02 09:40 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2019-08-02 09:40 UTC, Fedora Release Engineering
no flags Details
state.log (463 bytes, text/plain)
2019-08-02 09:40 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2019-08-02 09:40:30 UTC
upm failed to build from source in Fedora rawhide/f31

https://koji.fedoraproject.org/koji/taskinfo?taskID=36637945


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
Please fix upm at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
upm will be orphaned. Before branching of Fedora 32,
upm will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2019-08-02 09:40:32 UTC
Created attachment 1599756 [details]
build.log

Comment 2 Fedora Release Engineering 2019-08-02 09:40:34 UTC
Created attachment 1599757 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2019-08-02 09:40:36 UTC
Created attachment 1599758 [details]
state.log

Comment 4 Peter Robinson 2019-08-03 11:28:42 UTC
This is due to the rebase of nodejs and upstream hasn't added support to nodejs 12 as yet

Comment 5 Ben Cotton 2019-08-13 16:58:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 6 Ben Cotton 2019-08-13 18:32:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 7 Peter Robinson 2019-11-18 10:28:38 UTC
*** Bug 1773380 has been marked as a duplicate of this bug. ***

Comment 8 Miro Hrončok 2020-04-15 22:39:18 UTC
Let's do the same as in bz1721671?

Comment 9 Peter Robinson 2020-04-16 08:25:38 UTC
(In reply to Miro Hrončok from comment #8)
> Let's do the same as in bz1721671?

Yes please, feel free to just push the change and build, I'm massively behind on BZ because of release and product stuff.

Comment 10 Miro Hrončok 2020-04-16 09:39:49 UTC
A local build succeeded in a x86_64 mock. Trying a scratchbuild.

Comment 11 Miro Hrončok 2020-04-16 09:55:39 UTC
Running a regular rawhide build.

Comment 12 Fedora Update System 2020-04-16 11:59:17 UTC
FEDORA-2020-8eea868056 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-8eea868056

Comment 13 Fedora Update System 2020-04-16 19:28:58 UTC
FEDORA-2020-8eea868056 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-8eea868056`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8eea868056

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2020-04-23 18:02:31 UTC
FEDORA-2020-8eea868056 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.