Bug 173704 - switchdesk refers to /usr/X11R6/bin/twm etc.
switchdesk refers to /usr/X11R6/bin/twm etc.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: X11R6-MIGRATE
  Show dependency treegraph
 
Reported: 2005-11-18 20:55 EST by Sammy
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 11:03:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2005-11-18 20:55:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux; X11; en_US) KHTML/3.5.0 (like Gecko)

Description of problem:
Switchdesk refers to terminal binaries in /usr/X11R5/bin directory which no longer 
exists. Should be /usr/bin 

Version-Release number of selected component (if applicable):
switchdesk-4.0.7-1

How reproducible:
Always

Steps to Reproduce:
1. Look into switchdesk scripts  
2.  
3.  
    

Additional info:
Comment 1 Marius Andreiana 2005-11-20 14:34:09 EST
Shouldn't switchdesk be removed, as desktop selection it's done at gdm screen?
(and also saved per user)
Comment 2 Mike A. Harris 2005-11-23 12:39:22 EST
Now that modular X is in rawhide, please fix, so we can close the tracker
after all packages are fixed.

TIA
Comment 3 Ngo Than 2005-11-23 13:15:44 EST
I don't think it's a bug. It's a feature! switchdesk does not hardcode the
/usr/X11R6/bin, it just looks the binaries in WMPATH="/usr/bin /usr/X11R6/bin
usr/local/bin".

Comment 4 Rahul Sundaram 2005-11-23 14:26:05 EST
Could drop out /usr/X11R6/bin from WMPATH. Why not drop this entire package from
the distribution? The display manager allows you to switch DE's and set defaults.
Comment 5 Sammy 2005-11-23 14:28:52 EST
Which display manager? If you mean gdm, some of us are not using gdm but 
using kdm instead. 
Comment 6 Rahul Sundaram 2005-11-23 14:34:27 EST
(In reply to comment #5)
> Which display manager? If you mean gdm, some of us are not using gdm but 
> using kdm instead. 

File a enhacement to support this in KDM too. When implemented this package can
be dropped.
Comment 7 Ngo Than 2005-11-24 09:26:58 EST
why should we drop out /usr/X11R6/bin from WMPATH? It's a feature and it should
allows user to install another windowmanager under /usr/X11R6.

Comment 8 Rahul Sundaram 2005-11-24 09:36:06 EST
http://fedora.redhat.com/docs/release-notes/fc5/test1-latest-en/#id2577098

Everything is now installed directly into /usr instead of /usr/X11R6. All
software that hard codes paths to anything in /usr/X11R6, must now be changed
preferably to dynamically detect the proper location of the object, or to hard
code the new paths that X11R7 uses by default. It is strongly advised to use
autodetection methods rather than to hard code paths. 

If we implement session switching in KDM similar to whats provided in GDM we
dont require switchdesk in core anymore. 
Comment 9 Mike A. Harris 2005-11-24 09:55:17 EST
(In reply to comment #7)
> why should we drop out /usr/X11R6/bin from WMPATH? It's a feature and it should
> allows user to install another windowmanager under /usr/X11R6.

The /usr/X11R6/bin directory hierarchy is specified by the Filesystem
Hierarchy Stanadrd to be reserved for use by the X Window System.  That
is an exclusive directory for X11, and nothing else should ever put files
in there on an FHS compliant system.  The fact our OS permitted it for
so long was due to people being lazy to not fix things.

/usr/X11R6/bin is no longer in the path, and things that rely on this
directory structure are either broken now, or will break in the future.

While we can not directly control what 3rd party packages do, we must
update our OS to follow the FHS, and that means fixing packages in the
OS to not use or rely on /usr/X11R6 being present.

Please fix switchdesk.
Comment 10 Mike A. Harris 2005-11-24 09:57:55 EST
Also, the closing of this bug as NOTABUG earlier, ignores the fact that
the "twm" window manager, which is part of X11R7, is installed as
"/usr/bin/twm".  So, switchdesk wont find it regardless of wether you
choose to follow FHS or not.
Comment 11 Mike A. Harris 2005-11-24 10:06:23 EST
(In reply to comment #8)
> http://fedora.redhat.com/docs/release-notes/fc5/test1-latest-en/#id2577098
> 
> Everything is now installed directly into /usr instead of /usr/X11R6. All
> software that hard codes paths to anything in /usr/X11R6, must now be changed
> preferably to dynamically detect the proper location of the object, or to hard
> code the new paths that X11R7 uses by default. It is strongly advised to use
> autodetection methods rather than to hard code paths. 
> 
> If we implement session switching in KDM similar to whats provided in GDM we
> dont require switchdesk in core anymore. 

switchdesk works in any environment, wether you are using XDM, KDM, GDM, or
using startx or xinit directly.  It works with all X servers including
Xorg, XFree86, Xnest, Xdmx (in theory), Xvfb.

Putting session switching in KDM does not provide desktop switching
functionality for xdm, startx, or xinit initiated X sessions.  That is what
switchdesk exists for.

Note that this is not an argument to keep switchdesk in the distribution
however, just a clarification of an often misunderstood point of why it
continues to exist.  I have made enhancements to our xinitrc package over
the last few years to remove its dependence on switchdesk, and to genericize
the support for external window managers and desktop environments.  xinitrc,
and now xorg-x11-xinit, no longer have a hard requirement on switchdesk
for some time now.  Having said that, you can still use switchdesk to select
which desktop you use, and the X startup scripts will honour that regardless
of wether you use startx/xinit/xdm/gdm/kdm.

I believe it is a useful feature to have one unified mechanism for selecting
the default desktop/wm that works regardless of the method used to start an
X server.  If gdm and kdm use the same mechanism to configure things, that
is wonderful.  If you don't use gdm or kdm (I don't), then you need a way
to specify what desktop/wm you want to use, in a manner compatible with the
rest of the OS.  Right now that is done by changing /etc/sysconfig/desktop
configuration file - either by switchdesk, or by using a text editor.

I usually just hand edit the file personally, but I'd suspect that many other
users would be upset if they did not have a simple graphical way to select
which desktop they use.
Comment 12 Ngo Than 2005-11-29 11:03:39 EST
Mike, i want to make swichdesk independent of distribution and XFree/xorg version.
It should just work overall. It's the reason why i cannot remove /usr/X11R6 in the
search PATH!

Note You need to log in before you can comment on or make changes to this bug.