Bug 1737086 - machine-api-operator caused nightly builds to fail August 1 2019
Summary: machine-api-operator caused nightly builds to fail August 1 2019
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.2.0
Assignee: Julia Kreger
QA Contact: Jianwei Hou
URL:
Whiteboard: buildcop
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-02 14:45 UTC by Peter Hunt
Modified: 2019-10-16 06:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ironic-image pull 12 0 None None None 2019-08-02 15:43:06 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:42 UTC

Description Peter Hunt 2019-08-02 14:45:41 UTC
Description of problem:
machine-api-operator caused 4.2.0 nightly build to fail with the following error:
machine-api-operator contained an invalid image-references file

Version-Release number of selected component (if applicable):
4.2.0-nightly

How reproducible:
reproduced twice

Additional info:
https://openshift-release.svc.ci.openshift.org/releasestream/4.2.0-0.nightly/release/4.2.0-0.nightly-2019-08-02-002417
and 
https://openshift-release.svc.ci.openshift.org/releasestream/4.2.0-0.nightly/release/4.2.0-0.nightly-2019-08-02-075256

Comment 1 Russell Bryant 2019-08-02 14:52:59 UTC
This PR should resolve a build failure that occurred with ART, but not in OpenShift CI

https://github.com/openshift/ironic-image/pull/10

Comment 2 Julia Kreger 2019-08-02 15:47:29 UTC
Pull https://github.com/openshift/ironic-image/pull/12 created to get the fix to the 4.2-release branch.

Comment 4 Jianwei Hou 2019-08-12 05:44:45 UTC
I've managed to get newer nightly builds, so I think this is no longer blocking the builds.

Comment 5 errata-xmlrpc 2019-10-16 06:34:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.