Bug 173713 - libXext-devel: headers missing
Summary: libXext-devel: headers missing
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-19 08:18 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 21:40:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2005-11-19 08:18:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
All headers are missing from libXext-devel-0.99.2-1.i386.rpm.

ATM, most (all?) of them, are shipped as part of  
xorg-x11-proto-devel-0.99.2-1.i386.rpm
however, libXext-devel does not require xorg-x11-proto-devel:

# rpm -q --requires -p libXext-devel-0.99.2-1.i386.rpm
libXext = 0.99.2-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1



Version-Release number of selected component (if applicable):
libXext-devel-0.99.2-1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
Compile a package using headers from libXext (shape.h, multibuf.h etc.)

Actual Results:  Headers are missing.

Expected Results:  The headers should be present upon installation of libXext-devel.

ie. either the headers should be packaged as libXext-devel, or the libXext-devel should require the packages providing the headers.

Additional info:

Comment 1 Mike A. Harris 2006-01-31 21:40:50 UTC
* Tue Jan 31 2006 Mike A. Harris <mharris@redhat.com> 1.0.0-3
- Added "Requires: xorg-x11-proto-devel >= 7.0-1" to devel package (#173713)
- Added "libX11-devel" to devel package (#176078)



Note You need to log in before you can comment on or make changes to this bug.