Bug 1737167 - Abrt notifications not showing in Cinnamon
Summary: Abrt notifications not showing in Cinnamon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cinnamon
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-03 05:45 UTC by Chris Tao
Modified: 2019-08-15 18:09 UTC (History)
10 users (show)

Fixed In Version: cinnamon-4.2.3-2.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-15 18:09:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Chris Tao 2019-08-03 05:45:11 UTC
Description of problem:

Desktop notifications of app crashing is not showing in Cinnamon, whilst they do pop up in KDE and GNOME, on the same system. 

abrt-applet, abrtd, abrt-dbus, abrt-dump-journal-core are running. Crash reports are registered in gnome-abrt.

grepping "abrt" in logs yields nothing interesting.


Version-Release number of selected component (if applicable):
abrt-desktop-2.12.2-1.fc30.x86_64
cinnamon-4.2.2-1.fc30.x86_64


How reproducible:
Alawys


Steps to Reproduce:
1. Log into Cinnamon
2. Run "sleep 100 & ; kill -SIGSEGV %1" in terminal
3. Wait for notification


Actual results:
No notifications


Expected results:
Notification shows


Additional info:
I ran F29, F30 release isos in qemu, in F29 (with Cinnamon 3.x & abrt 2.11.0) I can receive abrt notifications, but not in F30.

I suspect either a Cinnamon or abrt upgrade causes this. Abrt was ported to GApplication/GNotification in 2.11.1, maybe it triggered a bug in Cinnamon's notification daemon. I can do further testing when I have time.

Comment 1 leigh scott 2019-08-03 07:29:56 UTC
Maybe file the issue against gnome-abrt.

Comment 2 leigh scott 2019-08-03 08:04:36 UTC
(In reply to Chris Tao from comment #0)

> I suspect either a Cinnamon or abrt upgrade causes this. Abrt was ported to
> GApplication/GNotification in 2.11.1, maybe it triggered a bug in Cinnamon's
> notification daemon. I can do further testing when I have time.


I'm not here to march to whatever tune the gnome plays, they need to still support the old method!

Comment 3 Chris Tao 2019-08-03 14:45:44 UTC
So I upgraded abrt to 2.12 in f29, then notification stopped working. 

> Maybe file the issue against gnome-abrt.

Fine.

Comment 4 ekulik 2019-08-04 12:26:13 UTC
(In reply to leigh scott from comment #2)
> (In reply to Chris Tao from comment #0)
> 
> > I suspect either a Cinnamon or abrt upgrade causes this. Abrt was ported to
> > GApplication/GNotification in 2.11.1, maybe it triggered a bug in Cinnamon's
> > notification daemon. I can do further testing when I have time.
> 
> 
> I'm not here to march to whatever tune the gnome plays, they need to still
> support the old method!

Cinnamon should implement the fd.o spec, then.

Comment 5 ekulik 2019-08-04 12:28:56 UTC
And it seems that it should work in Cinnamon, so maybe figure out the implementation before writing such incredibly toxic comments.

Comment 6 ekulik 2019-08-04 12:36:30 UTC
Chris, I can take a look at this, but not immediately, so, if you could do some more testing, I would appreciate it. Do any other applications that use GIO for notifications not work? Does using D-Bus directly work?

Comment 7 Chris Tao 2019-08-04 15:48:22 UTC
(In reply to Ernestas Kulik from comment #6)
> Chris, I can take a look at this, but not immediately, so, if you could do
> some more testing, I would appreciate it. Do any other applications that use
> GIO for notifications not work? Does using D-Bus directly work?

Thanks. So far it seems only notifications from abrt are missing in Cinnamon. Gnome-software and gnome-clocks work. I think they both use GNotifications. Calling the Notify method with gdbus works. Notify-send works.

I guess it is some weird interaction between Cinnamon and abrt-applet. I did run "abrt-applet -vvv" but had nothing helpful.
There is one occurrence of "unable to send notifications through org.freedesktop.Notifications timeout was reached" in logs during multiple crash tests. Don't know if that is related.

Let me know if I can help further.

Comment 8 ekulik 2019-08-04 17:10:55 UTC
Okay, thank you, I will let you know my findings.

Comment 9 ekulik 2019-08-12 08:17:06 UTC
Looks like it craps itself with notification icon being set to an icon name, so not really something for us to fix.

Comment 10 ekulik 2019-08-12 08:18:52 UTC
Maybe https://github.com/linuxmint/cinnamon/issues/7491? Though there’s no client crash.

Comment 12 Fedora Update System 2019-08-15 08:32:00 UTC
FEDORA-2019-10f2ef34b8 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-10f2ef34b8

Comment 13 Fedora Update System 2019-08-15 18:09:53 UTC
cinnamon-4.2.3-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.