Bug 173730 - Badness in interruptible_sleep_on_timeout at kernel/sched.c:3500 (Not tainted)
Badness in interruptible_sleep_on_timeout at kernel/sched.c:3500 (Not tainted)
Status: CLOSED DUPLICATE of bug 166152
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-19 15:35 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-20 15:32:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-11-19 15:35:16 EST
Description of problem:
Random, spontaneous error messages from kernel:

Badness in interruptible_sleep_on_timeout at kernel/sched.c:3500 (Not tainted)
 [<c033d1fc>] interruptible_sleep_on_timeout+0xf7/0x113
 [<c013096b>] group_send_sig_info+0x5d/0x67
 [<c012114e>] default_wake_function+0x0/0xc
 [<eec7f4db>] lockd_down+0xbe/0x120 [lockd]
 [<eec93df5>] nfs_kill_super+0x46/0x5b [nfs]
 [<c01745ad>] deactivate_super+0x80/0x91
 [<c01898fd>] sys_umount+0x33/0x73
 [<c018644b>] destroy_inode+0x3f/0x4e
 [<c01084d4>] do_syscall_trace+0x1e3/0x1f5
 [<c0189954>] sys_oldumount+0x17/0x1b
 [<c01040a5>] syscall_call+0x7/0xb


Version-Release number of selected component (if applicable):
kernel-smp-2.6.14-1.1688_FC5

How reproducible:
occurs spontaneously

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2005-11-19 15:46:51 EST
I think this may be only with SMP kernels.  The report above was on an i686 dual
process machine.  I also get a similar message on a single process x86_64 machine
(albeit this one is tainted with NVIDIA module).

Badness in interruptible_sleep_on_timeout at kernel/sched.c:3500 (Tainted: P     )

Call Trace:<ffffffff80369050>{interruptible_sleep_on_timeout+131}
       <ffffffff8013851a>{default_wake_function+0}
<ffffffff88a6a357>{:lockd:lockd_down+207}
       <ffffffff88a8796c>{:nfs:nfs_kill_super+77}
<ffffffff801963f9>{deactivate_super+132}
       <ffffffff801acea3>{sys_umount+662} <ffffffff80190fd8>{__fput+340}
       <ffffffff801abba5>{mntput_no_expire+28} <ffffffff8018e546>{filp_close+90}
       <ffffffff8010fb0a>{system_call+126}


Comment 2 John Ellson 2005-11-19 15:48:35 EST
I notice that NFS is implicated in both cases, but I'm not sure what extra info
you will need?   I'm using NFS over UDP to an old/stable RedHat-9 file server.
Comment 3 Pete Zaitcev 2005-11-19 16:13:22 EST
Steve, is that the case where it needs kernel_lock around the sleep_on?
Comment 4 Dave Jones 2005-11-20 15:32:24 EST

*** This bug has been marked as a duplicate of 166152 ***

Note You need to log in before you can comment on or make changes to this bug.