Bug 173731 - missing debugging support for ppc64
Summary: missing debugging support for ppc64
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker FC5Update
TreeView+ depends on / blocked
 
Reported: 2005-11-19 20:50 UTC by David Woodhouse
Modified: 2014-03-17 02:56 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 17:16:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 2005-11-19 20:50:36 UTC
The gdb.ppc64 and strace64.ppc64 packages are missing from the compose.

Including strace64.ppc64 is relatively simple, but for gdb I think we want some
installer support -- we should install only one of the 32-bit or 64-packages
according to the hardware, a bit like we do for the kernel.

Comment 1 Bill Nottingham 2005-11-21 17:17:45 UTC
One gdb/strace should support both ABIs.

Comment 2 David Woodhouse 2006-01-06 22:49:41 UTC
Any progress on this? We still don't have strace or gdb working for 64-bit
binaries on a clean install. Can we add it to FC5Blocker?

Comment 3 Roland McGrath 2006-01-06 22:58:27 UTC
The 64-bit gdb build should support both 32-bit and 64-bit binaries, so just
choosing gdb-*.ppc64.rpm in the install should dtrt.

strace is not going to support biarch on ppc until it gets a total rewrite.
It barely supports biarch on x86-64 and one or two others, and that support is
kludgey at best.  strace64 is a necessary evil for the time being (unless Bill
wants to maintain upstream strace).

Comment 4 David Woodhouse 2006-02-20 10:31:28 UTC
Did this get fixed for FC5t3?

Comment 7 David Woodhouse 2006-03-03 20:53:53 UTC
Hm. We now have a 64-bit gdb. Unfortunately, it's no longer capable of debugging
32-bit binaries. This would seem to be quite a recent development -- it always
_used_ to work.

bug #183931

Comment 8 Warren Togami 2006-03-08 17:02:50 UTC
Moving to FC5Update and FC6Blocker because this isn't related to install or
initial boot and we have no remaining time for FC5.

Comment 9 David Woodhouse 2006-03-08 17:16:37 UTC
Might as well mark this bug closed now. We can debug 64-bit userspace now... we
just can't debug 32-bit userspace any more :)

But that's bug #183931


Note You need to log in before you can comment on or make changes to this bug.