Bug 173732 - Include the ISC DHCPD LDAP patch
Include the ISC DHCPD LDAP patch
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
http://www.lunytune.net/isc-ldap.html
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-19 18:45 EST by Michael Fladischer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-21 14:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Fladischer 2005-11-19 18:45:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Description of problem:
Since bind already has the LDAP connectivity included it would be great to have LDAP support in dhcp too. This patch (http://www.lunytune.net/isc-ldap.html) seems to be around for some time now and should be well tested.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to use DHCP information from a LDAP tree in combination with the dhcp server.
  

Additional info:
Comment 1 Jason Vas Dias 2005-11-21 14:55:32 EST
We provide the ISC BIND LDAP support because it is included in the ISC BIND
source contrib/sdb/ldap directory, and many users have requested it .
The ISC BIND SDB support is provided in a separate executable, named_sdb, so
that users who do not need SDB support do not have to run a modified named.

There is no patch for dhcpd LDAP support in the ISC dhcp source contrib/
directory. If there was, we'd consider using it to provide a 'dhcpd_ldap' server.

This is the only request received so far for dhcpd ldap support.

If you'd like to see ldap support shipped in the standard dhcpd server, please
email a request for the inclusion of the LDAP patch in contrib/ to 
dhcp-hackers@isc.org - if it is shipped in the ISC contrib/ directory, we'll
consider shipping a dhcpd_ldap server .

Note You need to log in before you can comment on or make changes to this bug.