Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1737341 - ovn-northd is crashing when logical router has only IPv6 addresses and gateway_mtu is configured
Summary: ovn-northd is crashing when logical router has only IPv6 addresses and gatewa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux Fast Datapath
Classification: Red Hat
Component: ovn2.11
Version: FDP 19.F
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Numan Siddique
QA Contact: haidong li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 07:23 UTC by Numan Siddique
Modified: 2020-01-14 20:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-01 07:21:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2943 0 None None None 2019-10-01 07:21:53 UTC

Description Numan Siddique 2019-08-05 07:23:37 UTC
Description of problem:

Create a logical router and add few logical router ports connecting to logical switches with IPv6.
Add gateway_mtu option to the distributed logical router port (which connects to the provider network).
ovn-northd seg faults.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
When configured with the above steps, ovn-northd segfaults.

Expected results:
ovn-northd should not segfaukt

Additional info:

Comment 1 Numan Siddique 2019-08-05 07:24:40 UTC
This bug is because of the BZ 1702331

Comment 2 Numan Siddique 2019-08-05 07:26:02 UTC
Upstream patch to fix is merged - https://github.com/ovn-org/ovn/commit/7c311c9956650fedd6cb5b38ae836766444721f3

Comment 5 haidong li 2019-08-30 08:16:51 UTC
Reproduced on old version and verified on the latest version:
[root@dell-per740-04 openvswitch]# uname -a
Linux dell-per740-04.rhts.eng.pek2.redhat.com 3.10.0-1062.el7.x86_64 #1 SMP Thu Jul 18 20:25:13 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-per740-04 openvswitch]# rpm -qa | grep openvswitch
kernel-kernel-networking-openvswitch-ovn-1.0-135.noarch
openvswitch2.11-2.11.0-21.el7fdp.x86_64
openvswitch-selinux-extra-policy-1.0-13.el7fdp.noarch
kernel-kernel-networking-openvswitch-ovn_ha-1.0-41.noarch
[root@dell-per740-04 openvswitch]# rpm -qa | grep ovn
kernel-kernel-networking-openvswitch-ovn-1.0-135.noarch
ovn2.11-2.11.0-36.el7fdp.x86_64
ovn2.11-host-2.11.0-36.el7fdp.x86_64
kernel-kernel-networking-openvswitch-ovn_ha-1.0-41.noarch
ovn2.11-central-2.11.0-36.el7fdp.x86_64
[root@dell-per740-04 openvswitch]# 
[root@dell-per740-04 openvswitch]# ovn-nbctl set logical_router_port r1_s3 networks="2001\:db8\:103\:\:1/64"
[root@dell-per740-04 openvswitch]# ovn-nbctl get logical_router_port r1_s3 networks 
["2001:db8:103::1/64"]
[root@dell-per740-04 openvswitch]# ovn-nbctl set logical_router_port r1_s3 options:gateway_mtu=1442
[root@dell-per740-04 openvswitch]# virsh console hv1_vm00
Connected to domain hv1_vm00
Escape character is ^]

[root@localhost ~]# ping6  2001:db8:103::11
PING 2001:db8:103::11(2001:db8:103::11) 56 data bytes
64 bytes from 2001:db8:103::11: icmp_seq=1 ttl=63 time=1.85 ms
64 bytes from 2001:db8:103::11: icmp_seq=2 ttl=63 time=0.620 ms

--- 2001:db8:103::11 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1003ms
rtt min/avg/max/mdev = 0.620/1.236/1.853/0.617 ms
[root@dell-per740-04 openvswitch]# cat /var/log/openvswitch/ovn-northd.log
2019-08-30T07:31:20.420Z|00001|vlog|INFO|opened log file /var/log/openvswitch/ovn-northd.log
2019-08-30T07:31:20.425Z|00002|reconnect|INFO|unix:/run/openvswitch/ovnnb_db.sock: connecting...
2019-08-30T07:31:20.425Z|00003|reconnect|INFO|unix:/run/openvswitch/ovnsb_db.sock: connecting...
2019-08-30T07:31:20.425Z|00004|reconnect|INFO|unix:/run/openvswitch/ovnnb_db.sock: connected
2019-08-30T07:31:20.425Z|00005|reconnect|INFO|unix:/run/openvswitch/ovnsb_db.sock: connected
2019-08-30T07:31:20.426Z|00006|ovn_northd|INFO|ovn-northd lock acquired. This ovn-northd instance is now active.
2019-08-30T07:42:49.072Z|00007|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:49.074Z|00008|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:49.076Z|00009|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.275Z|00010|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.277Z|00011|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.279Z|00012|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.460Z|00013|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.461Z|00014|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.475Z|00015|ovn_northd|WARN|chassis name 'hv0' from redirect from logical  router port 'r1_s3' redirect-chassis not found
2019-08-30T07:42:58.479Z|00002|daemon_unix(monitor)|INFO|pid 31056 died, exit status 0, exiting
2019-08-30T07:43:09.065Z|00001|vlog|INFO|opened log file /var/log/openvswitch/ovn-northd.log
2019-08-30T07:43:09.071Z|00002|reconnect|INFO|unix:/run/openvswitch/ovnnb_db.sock: connecting...
2019-08-30T07:43:09.071Z|00003|reconnect|INFO|unix:/run/openvswitch/ovnsb_db.sock: connecting...
2019-08-30T07:43:09.071Z|00004|reconnect|INFO|unix:/run/openvswitch/ovnnb_db.sock: connected
2019-08-30T07:43:09.071Z|00005|reconnect|INFO|unix:/run/openvswitch/ovnsb_db.sock: connected
2019-08-30T07:43:09.071Z|00006|ovn_northd|INFO|ovn-northd lock acquired. This ovn-northd instance is now active.

Comment 7 errata-xmlrpc 2019-10-01 07:21:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2943


Note You need to log in before you can comment on or make changes to this bug.