Bug 1737351 - Console should show templates from current namespace in Developer Catalog
Summary: Console should show templates from current namespace in Developer Catalog
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1716700 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-05 08:02 UTC by shahan
Modified: 2019-10-28 14:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:34:53 UTC

Description shahan 2019-08-05 08:02:36 UTC
Description of problem:
  Console should allow uses create the objects defined in the template as 3.x we did. Now the user only can create the template in openshift namespace then have opportunity to create resources defined in template. This make the template public if user wanna use it in internal.

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-01-113533

How reproducible:
Always

Steps to Reproduce:
1. create template via import yaml button
2.
3.

Actual results:
It has not allow user create the resources defined in template rather than template itself

Expected results:
Should give a option to choose create resource for users  Or list the new created template on catalog page on dev console

Additional info:

Comment 1 Samuel Padgett 2019-08-07 20:44:46 UTC
I think the simple thing is to show templates from the current namespace in the developer catalog.

Comment 2 Samuel Padgett 2019-08-07 22:16:35 UTC
I've added templates from the current namespace to the Developer Catalog in

https://github.com/openshift/console/pull/2295

Note that the fix does not let you process templates from Import YAML, which is a much more involved change.

Comment 4 shahan 2019-08-13 05:57:51 UTC
User could add templates from the current namespace to the Developer Catalog.
Verify this bug.
io.openshift.build.commit.id=3d9532a92e0b2643418b8a51266cacdaec163a12

Comment 5 errata-xmlrpc 2019-10-16 06:34:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922

Comment 6 Samuel Padgett 2019-10-28 14:01:03 UTC
*** Bug 1716700 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.